Dataview queries fail in canvas when using special characters

Once you’ve done the above, delete everything above this line.

Steps to reproduce

Create a note with a tag that includes a special character. In my case I did

Source:: Sun Tzu 孫子

I can create a dataview table with

table without id
Quote, Stars as ⭐, as Link from #ideas/proverbs 
where Tradition = "Chinese" AND != "Proverb Note" AND Source = "Sun Tzu  孫子"
sort Stars desc

However, when I display this note in a canvas the query is empty. I can remove the Chinese characters from the tag and the query and it works as expected.

Expected result

I expected the note displayed on the canvas contain the query results.

Actual result

Queries with special characters are empty. I’ll attach screenshots.


Obsidian version: v1.1.16
Installer version: v1.1.16
Operating system: #1 SMP PREEMPT_DYNAMIC Fri Nov 4 18:35:48 UTC 2022 6.0.7-301.fc37.x86_64
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Dracula Official v1.0.7
Snippets enabled: 2
Restricted mode: off
Plugins installed: 28
Plugins enabled: 27
1: Calendar v1.5.10
2: Dataview v0.5.55
3: Hotkeys++ v0.2.7
4: Pane Relief v0.4.1
5: Periodic Notes v1.0.0-beta.3
6: Tag Wrangler v0.5.8
7: Text Format v2.2.1
8: Wikipedia v1.0.3
9: Workspaces Plus v0.3.3
10: Sortable v0.3.1
11: Recent Files v1.3.5
12: Paste URL into selection v1.7.0
13: Natural Language Dates v0.6.1
14: Hover Editor v0.11.9
15: Auto Link Title v1.4.1
16: ExcaliBrain v0.1.11
17: Excalidraw v1.8.21
18: Templater v1.16.0
19: Advanced Slides v1.20.0
20: Tasks v2.0.1
21: Icons v0.3.0
22: Emoji Shortcodes v2.2.0
23: Mermaid Tools v0.1.1
24: ProZen v0.3
25: Local REST API v1.5.2
26: Projects v1.14.0
27: Smart Typography v1.0.18

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

This is the note:

And this is how it appears in Canvas:

The actual queries:

I removed the special characters for one of the proverbs to show that it displays properly if the special character is removed.

Thank you for a lovely project,

we don’t provide support for third party plugins, report this to the plugin dev first.