Dataview Plugin in v1.4.4

I removed the snippets from the .obsidian folder in the root of my vault, but debug shows they are still loaded… even after closing and re-opening Obsidian

There are four different vaults that can be loaded, and the same snippets are probably in the hidden files in those vaults as well… ?

I’ll try downloading everything … Here is the new debug:

SYSTEM INFO:
Obsidian version: v1.4.4
Installer version: v1.3.7
Operating system: Darwin Kernel Version 22.6.0: Wed Jul 5 22:22:05 PDT 2023; root:xnu-8796.141.3~6/RELEASE_ARM64_T6000 22.6.0
Login status: logged in
Catalyst license: vip
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: Things v2.1.13
Snippets enabled: 5
Restricted mode: off
Plugins installed: 42
Plugins enabled: 1
1: Dataview v0.5.56

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Yeah try my suggestions in order. Snippets are the least likely problem. Seems to work fine for me:

---
Class: Shaper
Topic: Bits

---


```dataview
Table Class, Topic, Subject
where Class = "Shaper"
SORT "Topic"
```

How do I disable the snippets? I removed them from the .obsidian folder in the folder where this vault is located, but debug still shows them activated?

You go to the Appearance settings, and just toggle them off.

If you just removed the files, you likely have to restart Obsidian. But just toggle them off, and you can turn them back on when you are done testing.

I see you reinstalled, and edited your post above. And still not working?

Are you seeing any errors/warnings in the snippets? Can you show a screenshot or something?

I think I am still missing something… I did all the things you suggested. Updated my theme, removed the snippets as I said, but they still show up in debug ?

In settings under appearance, “CSS Snippets” -none found

Where can I disable the snippets showing up in debug?

this shows no snippets, but debug shows this

SYSTEM INFO:
Obsidian version: v1.4.4
Installer version: v1.3.7
Operating system: Darwin Kernel Version 22.6.0: Wed Jul 5 22:22:05 PDT 2023; root:xnu-8796.141.3~6/RELEASE_ARM64_T6000 22.6.0
Login status: logged in
Catalyst license: vip
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: Minimal v7.2.1
Snippets enabled: 5
Restricted mode: off
Plugins installed: 42
Plugins enabled: 1
1: Dataview v0.5.56

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I have no idea why your snippets are still showing up. But don’t miss this question ^

I don’t see any errors, but also don’t know where to look for any. I gave you the screen shot (above) where in settings it says there are none, but debug says there are 5.

Maybe I will put the snippets back into the .obsidian file and see if they show up in “settings”

… let you know.

I appreciate all the time you are spending to help me through this too!

Ok, I put them back into the .obsidian file and one of them (supercharged-links-gen) showed up in settings under appearance. I toggled this one on/off but the other four in debug do not show up here.

I tried Dataview in a Sandbox, and it works there. But not in my vault.

Here is the deebug from the Sandbox

SYSTEM INFO:
Obsidian version: v1.4.4
Installer version: v1.3.7
Operating system: Darwin Kernel Version 22.6.0: Wed Jul 5 22:22:05 PDT 2023; root:xnu-8796.141.3~6/RELEASE_ARM64_T6000 22.6.0
Login status: logged in
Catalyst license: vip
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 1
Plugins enabled: 1
1: Dataview v0.5.56

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

It’s interesting that no snippets show up.

Maybe I have to remove all the inf hidden somewhere in /applications…

  1. I’d like to see a screenshot of any error or warning where the Dataview query is, in your note.

Or a screenshot of how it looks. Just blank, or?

  1. Also a screenshot (or you just check) your Dataview settings. Are all the toggles checked on? You have to enable inline queries, for example.

  2. When there is a syntax error, it will show a warning. A good test might be to try this:

```dataview
TEST SYNTAX
```

You should see an error. If you don’t see a warning or error at all, that could be a good clue that Dataview isn’t functioning properly.

Perhaps this (from the developer) …

And this for details…

Whole thread might be worth a read. Backing up the vault as well could be prudent.

1 Like

FYI, the 3 .json files you have in your snippets folder belong in the .obsidian folder. They are not CSS Snippets.

Rigmarole: I get the same dataview error as above.

Thanks for this, but I did not see how the issue on the MAC relates to it. (I’m only superficially technical)

The strange thing is that others who use 1.4.4 have dataview working, and I had it working in the sandbox under the same version, but it won’t work in my vault.

Debug shows that there are 5 snippits active, but settings/Appearance shows only one.

Debug in the sandbox shows no snippits.

I thought that by removing the snippits section from the .obsidian file, I could remove them, but even after removing them from this file, they show up in the debug screen.

Donald

1 Like

I completely removed them from the .obsidian file, and it made no difference. I don’t know what they are from.

They are settings files. They belong in your .obsidian folder. You may have just accidentally moved them into the snippets folder.

Well, good that it is evaluating at least. That’s a start.

BACKUP FIRST!!! One of the replies from Licat is saying that it is possible the data that Dataview is storing might have bugs. I am not familiar with this process, but this is how you could potentially try to follow the instructions. BACKUP FIRST!!!

This shouldn’t affect the contents of your vault. But I am not familiar with the subtleties of this procedure. I assume this is just cached data that will be regenerated when you restart.

  • BACKUP FIRST!!!
  • Open Obsidian
  • Open the developer tools. F11 on Windows I think, alt-Cmd-i on Mac.
  • Go to the “Application” tab
  • On the left side, you’ll see a bunch of sections. Under “Local Storage”, and “IndexedDB”, try to delete any that are related to Dataview.
  • Restart Obsidian

Also, while you are in the dev tools, you could check the Console tab, and see if you get any errors.

Like this: Bug report: No available storage method found. · Issue #1282 · blacksmithgu/obsidian-dataview · GitHub

1 Like

Thanks for all your help. It is now fixed.

What I did:

I used the Atom Editor to correct the inline Properties I had throughout my Vault. (changing "Class:: " to "Class: " etc)

I created a new vault which I called “test_vault” and opened the developers console to watch for errors as I moved copies of my notes into this new vault.

I also created a dataview query and watched if it continued to work as expected as I moved notes into the new vault.

Eventually I found a note that created many console errors of “files that could not be found” so I isolated this note. In any-case this note did not impact the running of Dataview in this vault.

My original Vault (where Dataview did not work) still did not work. I used your procedure of opening the Dev Console and under applications, erasing the “IndexedDBs” starting with those of dataview. Once they were all erased, I restarted Obsidian.

Both my “test_vault” and my original Vault now worked with the Dataview plugin. I think that my inline properties which were not too consistent, broke the Dataview plugin.

Thanks for your help!

2 Likes

Awesome that you detailed all you did! I’m sure that will help others!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.