Dataview no longer works after changing date formats

What I’m trying to do

I made a section in my daily note for notes that were created today, based on this. It’s worked for a couple days, but it stopped returning anything after I changed all my date format settings.

TABLE string(split(string(file.mtime), ", ")[0]) as "Modified", string(split(string(file.ctime), ", ")[0]) as "Created"
WHERE file.cday = this.file.day
SORT file.ctime DESC

When I made my daily note template, I was using YYYY-MM-DD for my note titles. On a note titled 2023-01-03, the output looks like this:


But I decided to change all my date formatting to MM-DD-YY, and now the same note (titled 01-03-23) returns nothing:

However, it still works just fine if I change the note title back to 2023-01-03.

Things I have tried

I made sure all my date formats are correct in all my settings, as follows:

  • Daily notes (core plugin) is set to MM-DD-YY
  • Dataview date format is set to MM-dd-yy
  • Dataview date + time format is set to h:mm a, MM-dd-yy

I also tried making a new note from the template rather than renaming an old note, and results are the same.


When I take WHERE file.cday = this.file.day out of the dataview, it works as expected on all the files in my vault:

TABLE string(split(string(file.mtime), ", ")[0]) as "Modified", string(split(string(file.ctime), ", ")[0]) as "Created"
SORT file.ctime DESC

At this point, I have no idea what to try next. Would appreciate some advice!