Dataview: "Indices load ..." endless

I try to describe the Problem with the help of deepl:

Since the last update of Obsidian and Dataview, the queries no longer work.
I tried to find the cause by switching off all other plugins and reinstalling Obsidian.

Obsidian tries endlessly “Indices load…” and in the error message of the console (see below) I can’t find any hint to the cause.

But now I am slowly running out of ideas.

  • Problems and error messages when using Dataview produced untraceable errors in the console.

  • So we started from scratch:

MacOS 10.14.6

  1. deleted the entire Obsidian installation
  2. downloaded current version from website (0.12.3 universal)
  3. reinstalled
  4. installation checked and running
  5. installed plugin Dataview
  6. Obsidian tries unsuccessfully “Indices Load…”.

In the console the following error message:

Obsidian Developer Console
main.ts:35 Dataview Plugin - Version 0.3.x Loaded
index.ts:317 Dataview: Parsed all file prefixes (0.005s)
file.ts:358 Uncaught (in promise) TypeError: .for is not iterable
at eval (eval at (app.js:1), :10018:37)
at ()
at eval (eval at (app.js:1), :26:71)
at new Promise ()
at __awaiter (eval at (app.js:1), :22:12)
at extractMarkdownMetadata (eval at (app.js:1), :9993:12)
at FullIndex.eval (eval at (app.js:1), :10222:37)
at ()
at eval (eval at (app.js:1), :26:71)
at new Promise ()

Best to report bug reports for plugins directly to the plugin developer, typically via their GitHub Issues page. In this case, that’s:


i tried that too.

1 Like

interesting way to solve problems, thank you