[DATAVIEW HELP] This.file.link doesn't show in table

Things I have tried

I tried everything, I tested different notes to link them to ‘this.file.link’, it worked at first but after reopening the ‘this.file.link’ note it shows “0 results” and sometimes it shows all the notes in the “FROM” folder.

What I’m trying to do

Can someone help me solve this problem? I want this.file.link to have it dataview table with all notes whose category = ‘this.file.link’.

the dataview :

```dataview
Table file.mtime AS "Last Modified" 
FROM "300 - Map of Knowledge" 
WHERE contains(Category, this.file.link) 
SORT file.mtime desc
```

All the notes in the “from” folder while in the dataview there is the “Where” :

0 Results :

Hi.
Your query have the correct syntax. So, it doesn’t seem a query issue.
I don’t know if all the other values (the source, etc) are correct. If yes, well, you need to check if any plugin is the culprit. (disable others plugins, relaunch obsidian and try again)
Other thing: in the file where you insert the query the desired backlinks are present in the backlinks pane? (don’t forget that all files where you insert the link are also backlinks - inlinks - to your note)

1 Like

Another point I remember now.
I don’t know if it’s a dataview issue or not, but sometimes dataview doesn’t “like” that an inline field is the last content in the file.
In your both examples (“Untitled 1” and “Test 1”) give an enter and change the line after the link in your field.

1 Like

Hey! Some more things you could try:

  • I’m not sure how the contains function deals with links, maybe it’s safer to replace that with WHERE Category = this.file.link
  • To debug, I would temporarily add this.file.link and Category as fields to the table. Then you can maybe get more insight into why all the files in the folder are being loaded sometimes

Good luck :slight_smile:

1 Like

Hello,

Yes, it works now, you were right it was a dataview problem. Thank you very much for your help.

P.S: I’ve seen you a lot in the forum helping others, I just want to say, it’s so nice to help everyone effectively as you do, I really appreciate it!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.