Daily Note date is in incorrect format if created with command pallette OR if created on startup

Steps to reproduce

  1. Make sure you do not already have a created daily note for today
  2. command + P for command pallette
  3. Open today’s daily note

The date is in the default YYYY-MM-DD format, despite both settings in daily notes and templates being set to DD-MM-YYYY.

The correct format appears if the note is created with the calendar plugin, or when using the daily note template on a new note.

The same incorrect format appears if a note is created on startup using the ‘open daily note on startup’ setting, and there is no daily note created yet.

Expected result

The date to be in the correct format, specified in settings.

Actual result

Date is in default format


  • Operating system: Monterey
  • Obsidian version:0.12.19

I can’t reproduce. Post a screen recording of this happening in the help vault. Thanks

Hey. I have a screen recording but not sure where I should post it. Do you have a link?

you can upload it here, or upload it somewhere and add a link here.

Ok there we go.


Might be a minute for the video to process.

that is not the help vault.

Sorry, I misunderstood the meaning of ‘here’

Can you give me the link to the help vault? I don’t know where that would be

click on the ? in the lower left corner. It will open a vault without plugins/themes enabled.

We do not take bug reports if they are caused by plugins themes, So I am trying to figure out if this is Obsidian’s problem of if some of the plugins you have installed is creating this issue.

Ok, I think I got where the problem is. I’ll rewrite the bug report.

On daily note template, you need to explicitly add {{date:DD-MM-YYYY}} for it to work from new daily note creation.

Awesome, that indeed has fixed the problem.

For reference I couldn’t replicate on the help vault, but I still had the problem within the default theme.

I also only have a couple of the most popular core and most popular plugins isnstalled.

regardless, your format update has fixed the problem for me, thanks!