Customizeable hotkey for "Find previous"

Use case or problem

In most text editor apps that I use (on Mac OS / in browser), I can press Cmd + F to open the “search this document” dialog, type in my search term, press Enter to cycle through each next match, and press Shift + Enter to cycle backwards through the matches. In Obsidian, I can do most of this, except the “Prev” button keyboard shortcut appears to be hard-coded to Shift + F3 which is awkward on my Mac keyboard and is different from most other apps I use.

Proposed solution

My request is to make the “Prev” button hotkey configurable under Settings → Hotkeys, so I can override Shift + F3 to something more common (IME) such as Shift + Enter.

Current workaround

The hard-coded hotkey keeps falling out of my head, so my current workaround is to just click the Prev button instead of using the keyboard when I need to jump back to an earlier result match.

Thanks for reading!


Cool, I didn’t know you could do Shift+Enter on mac. Shift+F3 is from Windows lol.

One workaround for these kinds of bad key mapping defaults is the highly recommended BetterTouchTool (part of Setapp sub or purchasable independently) which lets you remap shortcuts for single apps.

Just learned that shift+cmd+G does work: On Mac, shortcuts for "Next/Previous Search Result" should follow the Apple Interface Guidelines (Cmd + G)

In 0.16.x, all 3 now work on macOS:

  • Enter and shift+Enter
  • cmd+G and shift+cmd+G
  • F3 and shift+F3

Yay! Thank you. This is awesome news.

However for me (MacOS, v0.16.2, installer v0.15.9) shift + enter still does not work (ie. does not jump to the previous match, rather it seems to have no effect).

Is this a situation where I’d need to download the latest installer and reinstall from scratch?

I have the same version. And shift+enter works. Dunno why it doesn’t work for you. You didn’t mess with BetterTouchTool or some other global keyboard shortcut setting, did you?

Nope, not to my knowledge. But if it works for you then I’ll assume it’s due to something weird about my environment. Thanks!

Is this a feature for Mac only? The SHIFT-ENTER binding for “find previous” doesn’t work in Windows. But it does work in other applications in Windows, such as web browsers.

False. Shift+Enter still doesn’t work for mac as of v1.0.0.

My bad, it was me who had BetterTouchTool mapping Shift+Enter to Shift+F3 for the Obsidian app. So that’s why it worked for me. Doh

shift-enter will be implemented in 1.0.4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.