Custom Hotkey 'Alt+R' isn't registering

I have a template named ‘Related’ that I’m trying to assign to the hotkey ‘Alt+R’ but it doesn’t register.

Things I’ve tried

  • Assigning the hotkey as Alt+ anything else works
  • Assigning the hotkey as Ctrl+Alt+R works
  • I’ve tried manually changing the hotkeys.json file, and as a result, ‘Alt+R’ is certainly displayed in the hotkeys menu, but when I try to use it to paste the template, nothing happens

It is literally only Alt+R that isn’t working.

Alternative I’m using

I’ve currently set it as Alt+Y, but it feels very off. I mean, sure one could argue that I can get used to it, but the whole point of note taking in obsidian (at least in my eyes) is no make the process as natural and seamless as possible. I always find myself hitting Alt+R instinctively before realizing ‘Oh, it was Alt+Y’.

Obsidian has actually made me enjoy taking notes and it feels weird that such a minor thing is adding friction.

Press Ctrl + Shift + I and check for error messages after attempting to use Alt + R for your template.

Can you assign Alt + R to anything other than the template, or does it not work for anything?

If you are using Templater, make sure that the file path in your hotkey settings is correct.

What OS are you using?

Maybe your system, or another app has an overriding hotkey mapped to that.

Testing on Windows 10, I can’t even map alt-r. And since you had to manually alter the json file, I guess you couldn’t either. So I’m guessing it is being captured by something else.

2 Likes

Alt+R isn’t working for anything.

And I’m pretty sure the file path is correct since Templater detected the template file itself.

Yes! It is Win 10! But isn’t it weird that Alt+R is presumably assigned to something? Like, iirc, native window commands are usually Win + [ ] right? Is there any way to clear up Alt + R so it can be used?

Just found this QnA about some shortcuts not even being available. What’s up with that? So random.

There are all sorts of hotkeys triggered with all sorts of modifiers. Win+whatever is definitely not the only one.

Also I just tested on MacOS. And alt-r (or option-r) is working fine. Definitely just a Windows thing and not an Obsidian thing. (Or an app or service running in Windows.)

I have no idea if there is a way to resolve this or even to identify what app has registered this. I’ve used “PowerToys Keyboard Manager” to help me fix some annoyances, like swapping the Apple and option key, so that the layout of my Mac keyboard would more closely match a PC keyboard. So I know it is quite flexible. But I don’t know if it will help you unmap this hotkey.

Alt + R is usable on my work machine, which runs Windows 10. It is a default hotkey for Templater.


Radeon software had it mapped on my home PC to start recording gameplay.

Here is a list of Windows 10 Keyboard shortcuts.

1 Like

Nice, I have an AMD card too. I’ll find and obliterate this app promptly. Thanks for finding that!