Cursor not moving when picking chinese characters

Steps to reproduce

  1. Open a new note
  2. Use chinese input method (i have tried two different chinese input styles) to type multiple characters without pressing enter to finalize the choice of words. this is indicated by the underline of the characters
  3. hit left directional key to choose the desired word for the character before
    (please note different chinese input methods work differently, so some may require a left + down directional key combination for selecting the previous character)

Expected result

Technically, the cursor should move one character left as you hit the left directional key to indicate you are now choosing words for the character before

Actual result

the cursor still appear at the end of the characters, while the box appeared for candidate words for the word before. So no problem with word choosing, just that the cursor did not move to indicate which word is being chosen at the moment.
This only happen with the editor. The cursor behaves normally when typing in the search bar, command palette, and renaming files, both at the title section or at the file explorer pane.

Environment

  • Operating system: Windows 7 (home) and Windows 10 (work) both observe this problem
  • Obsidian version: v0.12.12

Additional information


I am actually selecting desire words for the first character (which is a), but the cursor is still at the end of the line.


when typing at the title, the cursor moved to indicate which character i am choosing words for.

this trial is taken when safe mode is on.

This is a really minor problem but it really discourages me when typing chinese in obsidian. i currently use a third-party markdown app to work around this problem. hopefully some fix will come soon.
I suspect this problem is because editor is in some sort of source code mode, cause the same problem happened when i switched to source code mode in my third-party markdown app.

1 Like

I am not sure I understand your problem. Anyway I don’t recognize the IME your are using.
Does this happen with Microsoft builtin IME?

you know how the cursor moved when you are typing english? it goes to the left when you press your left directional key.
when you type chinese, you go through a process of

  1. inputting your alphabets (eg. a) which equivalent to your character
  2. pressing down / left directional key to have the desired word box pop up
  3. choosing you desire words (eg. 啊)
  4. press enter, and the choice of word is finalized

you can do this with multiple inputs of characters without finalizing your words, which means you can do multiple step 1s and only perform step 2 to 4 afterwards for words finalization. the cursor should (but didn’t) move along during words choosing process.

my IME is chinese (traditional) - new phonetic, it is Windows built-in.

I think there isn’t a cure though, cause I just tried out another markdown editor and it still happens. thank you for your quick response though!

1 Like

I have found a new IME for Obsidian.
Since this issue seem to occur with all markdown editors and no others seem to be using this IME, I suggest to close this topic.
Many thanks.

1 Like

May I ask for the new IME for Obsidian you found?
Because I have the same problem on it.