Cursor moving back into a link instead of continuing on line

Steps to reproduce

Type and write a link [[something like this]] continue typing after.

Expected result

write per normal

Actual result

cursor moves back into the link


  • Operating system: Mac OS Monterey 12.2.1 (21D62)
  • Debug info:
    Obsidian version: v0.13.30
    Installer version: v0.13.30
    Operating system: Darwin Kernel Version 21.3.0: Wed Jan 5 21:37:58 PST 2022; root:xnu-8019.80.24~20/RELEASE_X86_64 21.3.0
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Primary
    Snippets enabled: 26
    Safe mode: off
    Plugins installed: 105
    Plugins enabled: 59
    1: Auto Link Title
    2: Citations
    3: Daily Activity
    4: Recent Files
    5: Reading Time
    6: Find unlinked files and unresolved links
    7: Hotkey Helper
    8: Icons
    9: Natural Language Dates
    10: Pane Relief
    11: Related Notes Finder
    12: Templater
    13: Note Refactor
    14: Outliner
    15: Dataview
    16: MetaEdit
    17: Flashcards PAM
    18: Calendar
    19: Workbench
    20: txt as md
    21: Style Settings
    22: Mind Map
    23: Dangling links
    24: Vault Statistics
    25: Daily Stats
    26: Kanban
    27: Tracker
    28: Force note view mode
    29: Footnote Shortcut
    30: Pandoc Plugin
    31: Ghost Fade Focus
    32: Advanced URI
    33: Metadata Extractor
    34: Theme Picker
    35: Another Quick Switcher
    36: Org Mode
    37: Longform
    38: Tag Wrangler
    39: Supercharged Links
    40: TagFolder
    41: Calibre
    42: Cross-reference Navigation
    43: QuickAdd
    44: Obsidian42 - BRAT
    45: NLP
    46: Persistent Graph
    47: MySnippets
    48: Snippetor
    49: Linter
    50: Smarter Markdown Hotkeys
    51: Various Complements
    52: Prominent Starred Files
    53: Quick Explorer
    54: Markdown Attributes
    55: Admonition
    56: Excalidraw
    57: Task Collector (TC)
    58: Buttons
    59: Editor Syntax Highlight

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

I have updated all themes and community plugins

Additional information

Discord Video here

This is done in live preview mode. and if you refocus on another app + wait a while it seems to go away.

Also it doesn’t seem to always happen but like at least a few times a day.

thank you very much. Can you post a screen recording of this happening in the help vault?

Are you using some IME?

I think Supercharged Links may be causing this.

Might be related to this issue:

I have installed Supercharged Links, too. Turning of plugins didn’t change anything.