Creation of a mystery empty vault named "w" every time I open Obsidian

Hi I am having a mystery empty vault created every time I open Obsidian. I delete the folder/vault. And next time I restart Obsidian, it is created again! The vault is named “w”

My guess is that one of the plugins may be causing this creation. But in order to avoid the arduous process of disabling every single plugin and checking where this is happening, I was hoping someone could kindly guide me here.

Does anyone have an idea what this is and how I can prevent this from happening in future?

I don’t know why but it may be related to the link you use to open Obsidian.

  • Remove all your vaults and try again.
  • Open Obsidian from the main menu of your OS

Share the name of your current vault. Does it contain a w? After a quote or slash?

Otherwise, you should try

There is a keyboard shortcut to open a new vault. Its blank by default. Remove that in settings. Maybe it was accidentally set up.

I removed all the vaults except the one that’s open. I am guessing by this you mean X-ing out the vaults that show up on the left side bar when the “open another vault” dialog box is open. How do you remove the last one, i.e. the one that is open, without using Obsidian?

Yes did that. The name of the current vault is “Core Obsidian Vault”. And amongst other folders, it has again created a folder that simply has “w” title to it. Inside the folder there is a subfolder “.blocks” but it is empty.

I suppose you mean the one that is in hotkeys, right? Please correct me if I misunderstood. I checked and I removed the hotkey to open a new vault. There was no other shortcut to open a vault. After this, I again removed the “w” folder again, restarted Obsidian. But alas… it created the empty folder again.

The age old advice… turn on safe mode to disable the third party plugins. Load the default Theme as well. Its obviously something outside the core functionality. I could even see it being something in the OS like Auto Hot Key.

Yeah you are right. Turning on safe mode didn’t make the empty folder appear again. Argghhh…I have to now go through my 40 odd plugins one by one to figure this s**t out :sob:

Thank you though for your kind help.

1 Like

About your 40-odd plugins…you can disable 1/2 of them (the top half of the list for instance) and see if it still happens. And keep narrowing it down like that, by halves. It should go quicker than you might think. :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.