Crashed after downloading theme and can't get out - please help!

What I’m trying to do

Hey everyone, this is my first time posting because normally I’m pretty good at troubleshooting, but this has stumped me and I’m starting to get nervous.

I installed the Maple theme though the community themes in settings, and as soon as it was enabled it completely wiped the window and after trying everything I can think of I am unable to leave this page (pictured below).

Things I have tried

I’m unable to click on anything in the window and can’t access settings. I also can’t access the settings through the hotkey or through Obsidian > Preferences in the ribbon. Almost everything in the ribbon doesn’t do anything when I click on it. I was able to open the dev tools from the ribbon (the hotkey didn’t work), but this is a bit of a maze to me and I’m really not sure what I’m looking for. I feel like i just need to uninstall/disable the theme in some way but have no idea how to do that.

I’ve also tried quitting obsidian, force qutting and restarting my computer but this doesn’t change anything (it doesn’t even show the start up screen, just straight to this page)

I’m not super new with obsidian, and I’m not horrible when it comes to writing code, but anything outside of that, especially most of dev tools, is a mystery to me. Any help would be amazing, I’m so scared of losing my 300+ notes worth of data :frowning:

Update -

I was able to open a new vault through the ribbon, and this is opening a new default obsidian vault as expected. Seems like it is something in the maple theme that is doing this.

  1. would it be worth looking through the themes CSS in dev tools to try and see if there is something funky causing this? If so, where do you recommend starting with that?

  2. Is it possible to just move all of my files to a new vault and getting rid of the original vault entirely? What would be the consequences of this?

You shouldn’t have to mess with the Maple theme.css at all, something may have just gone wrong in the download/install. I was using it earlier and it was fine.

With the troublesome vault closed, using Windows File Explorer or the Finder, navigate to {YOUR-VAULT}/.obsidian/themes/ and remove the Maple folder. If that was what was causing it, when you reopen the vault it should load with the default theme (or maybe the last theme you used before Maple? - I can’t remember).

Either way, all your vault’s settings/themes/plugins/css snippets/etc. are in the .obsidian folder, so you can selectively remove things if you have issues or remove the entire folder. Your notes won’t be affected.

^ The .obsidian folder may be hidden depending on your OS settings.

Thank you so so much!! It worked!! I really overthinked this in my frantic anxious brain hey lol. Good to know for future, I was so scared of doing anything incase it messed up the whole vault! Cheers

Also ps, it opens the last theme used :blush:

1 Like

That was easy! :tada:

Ha! Good to know. I’ll jot that down.

Also, right now, right click on the vault and copy/paste it somewhere. Rename the copy 2023-11-15-MYVAULT (or whatever), and think about setting up a backup schedule.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.