Copy shortcut on Mac isn’t working

Things I have tried

I tried to restart Obsidian and Mac.
I am able to copy manually vis right/double click.
I am able to use copy shortcut only when I choose a word, open edit window in the top bar and then use command+C on keyboard.

What I’m trying to do

Hi, I am new to Obsidian so maybe I am doing something wrong… I am not able to copy anything inside Obsidian with keyboard shortcut command+C.

When I want to choose a word and then use a keyboard shortcut so it isn’t working

I am using MacBook Pro 2019 with macOS Monterey

Does it still happen if you test it in the Help Vault?

Do you have any community plugins installed? Does this still happen if you turn them off?

What version of Obsidian? And what is the installer version too?

It doesn’t happen in Help Vault. I can copy with shortcut there.

I do have community plugins but the problem is since I installed Obsidian. So even without plugins I have still the same problem.

Installer and Obsidian version is the same: 0.13.14

So that seems to mean it is something in your vault configuration. Then the next things I would look for:

  • Check your hotkeys. Did you map Cmd-C to something else?
  • Does it still happen if you switch to the default theme?
  • Do you have Vim key bindings turned on?
  • What happens if you turn “Legacy Emacs-style key bindings for MacOS” on or off? Any change?

And I don’t think it would be anything outside of Obsidian. Otherwise I would guess it would affect the Help Vault too. But:

  • Do you have any other applications installed that might be interfering with keyboard? Karabiner Elements, Espanso, Better Touch Tool, any auto-grammar tools?

Thank you so much. I had Toogle spellcheck shortcut for Cmd C. It is working now :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.