Contents of note was cleared

Hi all - I opened a note today and all its contents vanished, caput, cease to exist. And even when I try to open it through my computer it is still gone. Has this happened to anyone? Has anyone been able to get the contents of a note back after this happened? I’m scared, I feel like I could have learned to play guitar instead of creating that note. Also, the reason I have Obsidian is for its safety and so things don’t go missing.

Things I have tried

I have tried file recovery. nothing

What I’m trying to do

I would really like to recover the contents of my note and make sure that this doesn’t happen again.

Do you have Obsidian’s File Recovery enabled in Core Plugins.

Or is the plugin option there? Settings > scroll down to Plugin Options and click on File Recovery. Search for file name.

Are you using a 3rd party sync, like iCloud, OneDrive, etc? That can be one reason stuff like this happens.

What do you mean “nothing” when you tried File Recovery? Did you see zero snapshots? Or did you find snapshots that had no data inside them?

In “File Recovery”:

  1. You need to have the plugin enabled before you lost the data. It’s enabled by default, so you likely did. Just checking.
  2. You have to search for your file. If you just open File Recovery, you don’t see anything at first. You have to search for your file first. Then you should see a list of your snapshots.

Otherwise, you need to please share more information. OS. Obsidian version. Installer Version too. Are you using some community plugins?

Hi thanks for responding. I did have it on. I was able to find the file but there were still no contents in the file.

I am synched locally to a folder on my computer, not icloud or Onedrive.
I was able to find the File in file recovery, but the content wasn’t in there. I had it up and was working on it. I then exited out because it wouldn’t let me create another note, and when I opened it back up all the contents were gone.

More Info

  • Current Version 0.13.19
  • Installer version 0.12.19

Disclaimer, not a dev, just some guy…

Two issues.

  1. It sounds like… unless you have a backup of your OS files with a local or online service like backblaze, then your file content is gone. Besides the file recovery snapshot, Obsidian does not have a database of your files. The .md files are the content. The file recovery files are only kept for 7 days by default I think, though it still seems to keep at least the last snapshot. I set mine to 10000 days to be safe.

  2. Something very strange was going on for the file to blank like that, and I think a key phrase you mentioned was “I then exited out because it wouldn’t let me create another note”. I of course don’t know the technical details, but that sure sounds like a 3rd party addon causing instability, or possibly another application causing a conflict with Obsidian as both were trying to access the file at the same time. I doubt it was an issue with the core Obsidian app itself, as it just seems rock solid and there would be a ton of complaints.

I did notice you had an older installer version. You can remedy that by downloading the full installation again from the Obsidian site. It probably won’t change anything, but doing a complete install with the up to date installer is always a good idea. Check the snapshots again afterwards. Hope springs eternal.

1 Like

Thanks for you thoughtfulness and advice. I will redownload. When I checked it did say I was up to date. But I think figuring this out before I get any deeper is probably the best solution. Because as you said it does seem like my file it gone for good.

As a side bar: I don’t know what third party add-on I would be using. I haven’t downloaded and I’m not terribly tech savvy. I try and keep things pretty simple for my own well-being.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.