Confusing hint in quick switcher with "sometext.md" typed-in

Specifying filename including the markdown extension “.md” in “quick switcher” opens correct existing file after pressing Enter but displayed hint on the right side still incorrectly suggests “Enter to create”.
Windows7, Obsidian 0.8.4

I can’t repro. Let me know if you still get this when we release 0.8.8

Thank you @WhiteNoise, I will test again in 0.8.8 and let you know.
For now, more info in printscreen:


Maybe it is due to having the note in subfolder of the vault. It shows correctly when file is directly in Vault root folder.

I understood your problem. I can’t repro on 0.8.8. You can also try to delete your .obsidian/cache

ok, I tried again. It seems that it happens on some files and does not happen in other cases. I haven’t figure out why.

Another observation: for files in root folder, search is case sensitive so incorrect capitalization results in the same incorrect informative texts as mentioned above.
But fortunately, it always opens the existing file.

Update: I tested again in Obsidian v0.10.1.

Before testing I did the following:

  • Closed Obsidian
  • Dragged all files out of C:\Users\UserName\AppData\Roaming\obsidian\ObsidianCache
  • Dragged file ‟workspace” out of C:\Users\UserName…\ObsidianVault.obsidian
  • Started Obsidian again by: run “C:\Users\UserName\AppData\Local\Obsidian\Obsidian.exe”

Differences from previous reports:

  • Previously it worked correctly for files in Vault root folder as mentioned in post #3 ↑. Now it uniformly does not work anywhere. That might be easier situation for debugging.
  • Now the extension is shown also within suggesting under input box, in contrast to older screenshot in post #3 ↑ (which does not matter to me.)
  • Case sensitivity mentioned in post #6 ↑ seems to be fixed, i.e. search is case-insensitive.

I understand this is just a matter of recognizing the .md . It’s not a big deal.