Conflict between "Alt+number" shortcut and "Alt+Code"

I’m not sure that it should be consider as a bug or feature request.

Steps to reproduce

Bind a keyboard to Alt + Number.
In my case : Set heading 1 => Alt+1
Set heading 2 => Alt+2

Expected result

  • Alt + Number 1-6 triggers “Set heading 1 - 6”
  • :heavy_check_mark: Alt + Code are not affected. Alt + Code trigger the chosen caracter and doesn’t trigger Alt + Number shortcut.

Actual result

  • Alt+Number 1-6 triggers “Set heading 1 - 6”
  • :x: Alt+Code are affected. They are not usable. Alt+Numpad triggers obsidian shortcuts with Alt+Numbers instead of Alt code.

Actually, obsidian discriminate Alt+Numbers from Alt+Numpad if distincts shortcut are set in the config.

Example : One feature, Ctrl+1 and another Ctrl+Numpad1.
With that setting, the two shortcuts triggers two different features.

If nothing is set for Ctrl+Numpad1, obsidian will see it as Ctrl+1.
This is problematic 1/ for Alt+Code and 2/ maybe problematic for other uses ? Maybe user using Numpad as shortcuts for other things ?


:bulb: 1. fully discriminate numbers from numpad. Or let the user enable “if no obsidian shortcut set for numpad, use numpad as “normal” numbers”.
:bulb: 2. Just disable Alt+Numpad triggering features set with Alt+Number.


  • Operating system: Windows 10

Thanks for your consideration.
All the best ! :sunny:

1 Like

I don’t consider this a bug. Search/Open a feature request.