Combining acute shifts on Cyrillic characters

I am using a macOS and typing text in Cyrillic characters using U+0301 combining acute accent Unicode character. In the TextEdit application the acute is placed correctly, but in Obsidian it is shifted. What am I doing wrong?

Screenshot 2023-10-03 at 14.33.01

Accent is displayed incorrectly when using U+0301 combining acute accent Unicode character with Cyrillic. I type the word ударе́ние in the TextEdit application and there the accent is displayed correctly but in Obsidian it is shifted.

Screenshot 2023-10-03 at 14.33.01

Please follow the template when submitting bugs. Moved to Help for now.

You should go through the debugging steps, test in the Sandbox vault, and if none of that works, include more info.

Can you explain more info about your keyboard and language/region settings so this can be reproduced? I copy/pasted your word, and it looks fine in my setup.


Debugging steps:

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

Also I combined your posts, since you posted the same topic twice.

Closing this because now you have opened a bug report: Combined accent displays incorrectly with Cyrillic characters