Cmd-opt-n hotkey shows as cmd-opt-backtick

Steps to reproduce

On Obsidian 1.3.5, (macOS 13.1) when I go to Preferences → Hotkeys → Hotkey search, and hit cmd-opt-n, the search displays cmd-opt-backtick.

This reproduces in the sandbox vault, and after restart.

This does not appear to happen for any other chords I tried, e.g. cmd-ctrl-n.

By contrast, when I go to (macOS) System Settings → Keyboard Shortcuts → App Shortcuts and try to create a new shortcut there, bound to cmd-opt-n, it displays the correct key combination. So I know it’s not something at the OS level. (Works similarly in other programs with bindable key mappings, e.g. SublimeText)

Did you follow the troubleshooting guide? [Y/N]


Expected result

Pressing cmd-opt-n yields the key combination cmd-opt-n

Actual result

Pressing cmd-opt-n yields the key combination cmd-opt-backtick


Obsidian version: v1.3.5
Installer version: v1.3.5
Operating system: Darwin Kernel Version 22.2.0: Fri Nov 11 02:03:51 PST 2022; root:xnu-8792.61.2~4/RELEASE_ARM64_T6000 22.2.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 5
Plugins enabled: 5
1: Dataview v0.5.56
2: Better Word Count v0.9.6
3: File Tree Alternative Plugin v2.3.4
4: QuickAdd v1.2.1
5: Templater v1.16.0

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

1 Like

I can reproduce this in 1.3.5 on MacOS.

1 Like

which keyboard layout do you use?

For me, I use standard Apple keyboards U.S. physical layout, set to Querty Canadian English.

It also happens in 1.2.6 (installer 1.1.16)

1 Like

US keyboard layout here.