Cmd+A in the search field doesn't select all text (Known issue with Community Outliner plug-in)

Steps to reproduce

  • Type in a search term
  • Cmd+A to attempt to select all to retype the search term
  • Type a new search term

Expected result

  • Old search term should be replaced with the new search term.

Actual result

  • New search term is appended to the old search term.


  • Operating system: MacOS Big Sur 11.2.3
  • Obsidian version: 0.12.1

Additional information

Cmd+End, Shift+Cmd+Left to select all and then either delete or type over the value works.
Navigate to the Clear Search button and click to clear the search text works.

Known issue with Community Outliner plug-in. Disable the Outliner plug-in until it is fixed. Already reported in GitHub.

This doesn’t happen for me. I tried it in both the Search tab and in the Cmd-F search inside a note’s pane. I select all using Cmd-A and then type, and the entire text field is replaced with the new text. I tried starting with my cursor at the end, or in the middle between words.

Same OS and version. (edit: I tested both Big Sur 11.2.2 and 11.2.3. I can’t reproduce this problem. It works for me.)

(I wondered if maybe this has anything to do with insert mode, but now I don’t even know if MacOS has an insert mode, and I don’t have an insert key to test.)

  • Do you have any software installed that manages hotkeys, macros, or snippets?
  • Have you tried with all community plugins disabled?
  • Does this also happen in a fresh clean vault with no plugins?

Hmm. I can’t reproduce this one either. MacOS 11.2.3, Obsidian 0.12.1 and a bunch of plugins.

It’s caused by the Community Outliner plug-in.

I’m not sure what this means. Are you saying that you think the problem was caused by the official Outline plugin? If you turn it off the problem goes away for you? Please elaborate?

I also have the Outline plugin enabled, and don’t experience the problem.

Edited for clarification. Not the core Outline plug-in, the community Outliner plug-in.

1 Like