Cloudflare Issue

I’m trying to use Cloudflare with Obsidian Publish, but continue to get a 404 when visiting my site. I’ve tried different settings. Attached is my current config. Using Full (Strict) SSL right now, but did try regular Full SSL as well. Same result. Name servers are correct. Can’t figure this out.

1 Like

In Cloudflare try going to
SSL/TLS > Edge Certificates
and turn on ‘Automatic HTTPS Rewrites’
Just because I have it on and it all works fine for me.

Have you set the custom domain inside Obsidian > Publish ?

This sounds like an issue in Obsidian not Cloudflare, as 404 comes from the Obsidian server not from Cloudflare.

Can you access in incognito as per this post:

I got things kinda working by inputing the custom domain in Obsidian publish, so now works, but yields DNS_PROBE_FINISHED_NXDOMAIN, which I guess makes sense. Something does seem to be misconfigured on Obsidians end.

Using two domains (e.g., with www. and without www.) is not yet supported, unfortunately.

You need to setup a page rule.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.