Clicking on a note pane or opening a note, forcibly reveals the note in navigation

Issue: Clicking on a note window or opening a note, forcibly reveals the note in navigation

Steps to reproduce

  • Use Obsidian 12.16 on MacOS 11.6
  • open any note or file, or click on any open note pane
  • Note can be opened from navigation list directly, through CMD-O or through a link in another note

Expected result

  • The note opens or the note pane becomes active
  • the navigation pane does not change state

Actual result

  • the note is revealed in navigation in the same way that the “Reveal file in navigation” button will do it.
  • if the file navigation pane is minimised, it will open the pane and reveal the file.
  • This is very annoying


  • Operating system: MacOS 11.6
  • Obsidian version: Obsidian 12.16

Additional information

  • I recently reinstalled MacOS on my Mac from scratch and installed Obsidian using installer version 0.12.15
  • I can’t be certain, but I believe this issue started when I installed Obsidian update 12.16
  • The issue is present regardless of any settings I can find
  • Issue persists with no community plugins installed
  • issue ceases when I disable “File Explorer” core plugin

please post a screen recording of this happening in the help vault.

I just tested it, the issue doesn’t occur in the help vault

Some plugin is causing you this problem.

That makes sense. The confusing part is that it persists even after disabling all core and community plugins, with the exception of the file navigation plugin.

could a plugin be affecting this even when it is not enabled?

have you tried disabling the thirdparty plugins and restarting obsidian?

1 Like

Lo and behold! That fixed it. I guess there was a cache somewhere with the gremlin.
Of course, in the end “have you turned it off and on again” was what did it.

Thanks WhiteNoise!

How do I mark as solved?

If you find which plugin did this, please open a BR to the author of that plugin because disabling plugins should cleanup things and not need a restart.

was it this plugin Automatically Reveal Active File ?

I did at one point have that plugin installed, so its possible. but I had already uninstalled it and when the bug was occurring. Though I don’t think I had disabled plugins AND restarted Obsidian since I uninstalled