Chromium Display Bug - MacOS - Blue Lines

There is a known bug in the Chromium engine that affects all Electron apps, of which Obsidian is one. It causes blue and green distortions on all windows. This is due to a GPU rendering issue for some recent MacBook Pros.

Here is a screenshot
See https://bugs.chromium.org/p/chromium/issues/detail?id=1068170 for full details.

Steps to reproduce

  1. Change display modes, or wake the Mac from sleep.
  2. See distortions.

Environment

  • Operating system: MacOS 15.7
  • Obsidian version: 0.9.11

Additional information

There are only two effective work-arounds:

  1. Go to System Preferences > Energy Saver and restart the Mac. This prevents future occurrences but limits your ability to use the GPU for other applications.

  2. Open up Activity Monitor, and view the CPU tab. Filter for the process 'Obsidian GPU" and repeatedly force quit the process or processes until the visual distortions disappear.

NOTE: This is not an Obsidian issue per se; however it might be helpful to offer a toggle for disabling GPU rendering until the issue is fixed.

Hello!

I’m getting this previously-reported graphical issue in Obsidian (and in Chrome itself) from time to time that does not go away until I do a full reboot (and seems to come back after a certain amount of time anyway). I believe that this is an issue with Chromium and Apple’s GPUs on 16" macbook pros, as gone over in this chromium bug thread.

From that thread, it seems that a temporary stop-gap solution is to disable hardware acceleration, which has actually resolved it on the Chrome side. I can’t figure out how to disable it from the Obsidian side, and that’s likely because it’s not exposed unless the developer of a chromium application exposes it.

Can the ability to turn off hardware acceleration be an option in the Obsidian UI?

Here’s a screenshot of what I saw earlier today:

2 Likes

@Licat this one might be critically important for a few users!

I’m not too familiar with the command line switches of Electron but can you try the ones mentioned in https://github.com/electron/electron/issues/20702 and let me know if any of them works?

I had similar graphical problems appear in Chrome and Obsidian after suspending and waking up my computer. (Ubuntu 16.04 with Nvidia drivers)

I solved this by using the flag --disable-gpu.

I run Obsidian using ./Obsidian-0.9.3.AppImage --disable-gpu, which disables hardware acceleration.

1 Like

Spoke more in the Discord, but yeah I ran it like so:

$ ./Obsidian --disable-gpu --disable-software-rasterizer

…and haven’t seen the issue since. I don’t know if that means the problem has gone away entirely, since the problem was intermittent for me before, but I’ll comment on this thread again if I see the issue crop up again.

1 Like

I’m curious—has anyone who’s disabled GPU acceleration experienced performance losses? I wonder how much of a difference it makes.

I haven’t, but I don’t have a particularly large database yet. Idk if it’d affect folks that do have a large db.

1 Like

Hello,
Today morning everything was ok, but now both editor and preview node are unreadable. All screen is blue. Settings window is ok.

I have last public version of Obsidian 0.9.15, installer was 0.9.3, as os i have MacOS 10.15.7

@TwoBlueCats have you run Obsidian in the manner that I did here?