Chinese IME issues in Windows 1909

Same problem. And I have to turn off the “fold heading” option for better type experience.

For those who also meet this Windows IME issue, here is a temporary solution which currently woks perfect for me:

  1. Download and install Auto Hotkey (AHK)
  2. Create a new script(.txt to .ahk) with the following code:
:*:#::{u+0023}
:*:=::{u+003d}
:*:~::{u+007e}
:*:%::{u+0025}
  1. Save and run!

Now we can wait for the official patch to solve it in the future :smile:

1 Like

Is there any update on this issue?

Here is another similar case with Windows IME:

To reproduce the issue, please use the help vault and create a new note, then use Windows default Chinese IME.

  1. In the first line, type “Anything Bold
  2. In the second line, type anything you like
  3. Put the cursor at the end of the first line, then press two numbers, such as “11” (please use Windows default Chinese IME)

You can see that the second “1” is selected, which is not supposed to happen.
My device: WIndows 10, 1909

IME Bold Text Issue

Please note: It seems that this issue not always happen, but around 80% chance.

We can’t reproduce this issue.

Have you tried on a more recent version of windows 10?

What keyboard do you use exactly?

I can’t repro with the exact steps. Windows 10 20H2 (but I couldn’t repro these issues before I upgraded from 1909 either).

Also it might help to show your Pinyin options. This (all default values) is what I’m using to test:

Thanks for your reply, I have checked with my Pinyin setting and it looks the same as yours, but I don’t have the last “Compatibility” option.

Because the system is governed by my IT department so I’m not able to update currently. I will wait for my IT department to update my device.

Another Issue - 1

And following is another IME issue I just found, no idea if there is any similarity:

  1. Type something like BoldSome Text
  2. Put the cursor after the last “*” and before “S”
  3. Use Chinese IME and press and hold 1

You can see that the “S” is in the wrong place
Windows IME Bold Cursor Issue

Another Issue - 2

And another IME issue I just found…again:
Type some contents and put the cursor before these contents, then use Windows IME to type something, and before press “Enter”, use mouse to move the cursor to some where else, please see the details as following:
Windows IME cursor with mouse issue
I’m not sure if this is the right place I should report it, so if it’s the wrong place please tell me and I will modify it.

Thanks for the time and efforts again!

Do you have a personal computer? Does it happen there?

I am not convinced this is just an ime issue because we can’t reproduce it. There must be something else on your computer that is causing this. It would be better if you let us know if this happens on a clean windows installation.

Please ignore the “Another Issue - 2” part… sorry for that because it happens every where…

I will try to use another device later this week, thanks!

I am unable to reproduce “Another issue 1” nor “Another issue 2”.

test

test

Please replace ‘1’ with ‘,’
Honeycam 2022-03-04 00-38-04

the issue with is a different one and was likely fixed in 0.13.25

Hi @Licat & @WhiteNoise,

I have checked these issues on a different (and clean) device which runs Windows 10 21H1, since lots of different topics were shared in this post, I have summarized all the information I have so far as follows, kindly please have a look, thanks!

(And as always, all the tests were made in the help vault and please use Windows 10 default Chinese IME.)

Part 1 - Common Issues

Common means I can reproduce the issues on both Windows 10 21H1 and Windows 10 1909.

Issue 1.1 - Cursor in the wrong place when inserting between symbols and texts

To reproduce:

  1. Type some bold texts and then type some regular texts (such as: **Bold**Regular Texts)
  2. Place the cursor after the last * and before the first regular text(R)
  3. Press and hold (please use Chinese IME)

IME Issue 1-1

You can see that the cursor is in the wrong place.

For Issue 1.1, if you use source mode, then it will be solved.

Issue 1.2 - Cursor in the wrong place when editing headers

To reproduce:

  1. Turn on the Editor setting - Collapse Heading
  2. Type a markdown header (such as: #### Header) and make sure there should be some texts below the heading
  3. Select the #### (with space) part
  4. Type (please use Chinese IME)

IME Issue 1-2

You can see that the cursor is in the wrong place (again).

For Issue 1.2, if you turn off Collapse Heading, then it will be solved.

Issue 1.3 - Punctuation gets selected

To reproduce:

  1. Type some bold texts (such as**Bold**) and add a line below it
  2. Place the cursor after the last * and press (please use Chinese IME) for several
    times

IME Issue 1-3

You can see that the second is selected.

For Issue 1.3, if you use source mode, then it will be solved.

Part 2 - Issues only on Windows 10 1909 or Previous version of Microsoft Pinyin

To reproduce the following issues, you can use Windows 10 1909. Or if you have already updated to Windows 10 20H2 or later, please switch the Compatibility to use previous version of Microsoft Pinyin (in the bottom of the screenshot you shared previously about Pinyin options).

Issue 2.1 - Number(#) gets selected or cursor wrong place

To reproduce:

  1. Turn on the Editor setting - Collapse Heading
  2. Create a note with several lines
  3. Put the cursor in the middle of the note and on a blank line
  4. Press # for several times (please use Chinese IME)

IME Issue 2-1

You can see that sometimes the # gets selected, sometimes the cursor is in the wrong place.

For Issue 2.1, if you turn off Collapse Heading, then it will be solved.

Issue 2.2 - Some symbols(=~%) duplicate

To reproduce:

  • Just use Chinese IME and type = or ~ or %

IME Issue 2-2

You can see that these symbols get duplicated.

Currently I haven’t find any solutions to mitigate this issue, so the only choice is to use Legacy Editor to avoid this.

Summary

In total, there are five issues, the first three can be reproduced on both the new Windows 10 21H1 and the old Windows 10 1909; the last two can be reproduced on the old Windows 10 1909 and on the Windows 10 21H1 but you need to switch to use the previous version in the Microsoft Pinyin IME Compatibility setting.

(These issues do not happen on Legacy Editor or Live Preview with English keyboards.)
(All of these issues can be reproduced. If not, please try again.)

As you can see, these cases are not rare cases. I believe (and have heard) many Chinese users (maybe also Japanese, etc. users) are bothered with these issues.
Kindly please spend some time on these issues. Sorry for causing you trouble and many thanks for your efforts on creating Obsidian as always! Hope to see these issues get solved soon!

Thanks again!

1 Like

2 posts were merged into an existing topic: Windows IME issues with Chinese punctuation symbols

I moved the problems with chinese punctuation to a separate thread. The problems specific to Win 10 1909 won’t likely get addressed.

Fully understand. I will wait for your fix on those common Chinese IME issues first. Hopefully the Windows 1909 issues may also get mitigated by then.

Meet the same situation.
cursor.zip (119.8 KB)

Here is a mitigation solution

I seem to have a fix that resolves all of these issues in the upcoming 0.14.3 release.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.