Characters occasionally removed while typing in vim mode

Steps to reproduce

Use Obsidian in vim mode
Type a few paragraphs (while in insert mode)
observe characters appearing and subsequently being removed occasionally

Expected result

The paragraph would be typed in full

Actual result

The paragraph will mostly get typed, but many characters will be removed

Environment

  • Operating system: Manjaro (arch) linux
  • Obsidian version: 0.10.1

Additional information

This doesn’t happen in any other text field in any application on my machine. I don’t use any third party plugins or css. Some brief testing with vim keybindings turned off did not produce the same issue.

can you provide exact reproduceble steps?

I am having a similar problem with 0.10.1 on Ubuntu.

Not using Vim, but I am having characters randomly being removed while typing in a note that is open in 2 panes at once.

It seems to happen more in big vaults / long notes with lots of formatting.

As of now I can’t provide exact steps to reproduce – this is all I know at the moment.

1 Like

What I wrote in the ticket is pretty much exactly what I do, I can write a user story though:

  • open up obsidian
  • open any note
  • enter vim insert mode if you aren’t already in it
  • start to type
  • observe characters being removed as you type

are you sure you didn’t add\change some custom shortcuts? do you have third party plugins?
What’s your installer version?

For my part, I have no 3rd party plugins (safe mode is ON). My installer is 0.9.20.

@Sentiment I am not even sure you have the same bug.

I have the exact same problem in Kubuntu as well.

1 Like

I opened a separate bug report Characters skipped when typing in a note open in 2 panes