Canvas: Zoom doesn't work reliableg

Steps to reproduce

Set default mouse wheel behavior to: ZOOM
Open a canvas.
Try to zoom with the mouse wheel scrolling up/down.

Expected result

Zooming in/out

Actual result

It starts panning and zooming at the same time in random patterns.


Obsidian version: v1.2.7
Installer version: v1.1.16
Operating system: Darwin Kernel Version 21.6.0: Thu Mar 9 20:12:21 PST 2023; root:xnu-8020.240.18.700.8~1/RELEASE_ARM64_T6000 21.6.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Minimal v6.3.2
Snippets enabled: 0
Restricted mode: off
Plugins installed: 11
Plugins enabled: 9
1: Calendar v1.5.10
2: Outliner v4.6.5
3: Projects v1.15.3
4: Tasks v3.5.0
5: Dataview v0.5.55
6: Kanban v1.5.2
7: Text Generator v0.3.17
8: Omnisearch v1.14.0
9: Text Extractor v0.4.3

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Not a bug, this is intentional. zoom in is centered on the pointer, zoom out is centered workspace center.

1 Like

Thank you for the fast answer. But let’s say I center my mouse on a specific item and I want to zoom in. All it does is panning up (like it would be set to pan in the settings). And just sometimes zooms in (randomly). I might do a screen recording if I get a chance.

are you pressing some keys in the keayboard at the same time?

Not at all.

All I use is the scroll wheel of my Logitech G203 mouse - which works fine across all other apps.

So it seems like it is an issue with the scroll wheel of that particular mouse. I tried it with the magic mouse and the zooming in/out works as it should. Any thoughts?

no sorry

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.