Canvas: unexpected file deletion

Steps to reproduce

  1. creat a canvas group with over two cards
  2. delete its cards, with only one or none left

Expected result

the card is deleted

Actual result

this canvas file is deleted


  • Operating system: windows 11
  • Debug info:
    Obsidian version: v1.1.6
    Installer version: v1.0.0
    Operating system: Windows 10 Home China 10.0.22000
    Login status: logged in
    Catalyst license: insider
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Obsidianite v0.0.0
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 59
    Plugins enabled: 46
    1: Admonition v9.0.5
    2: Another Quick Switcher v7.5.2
    3: Better Command Palette v0.14.0
    4: Calendar v1.5.10
    5: Commander v0.4.4
    6: Convert url to preview (iframe) v0.5.0
    7: Custom Frames v2.4.4
    8: Zoom v1.1.1
    9: QuickAdd v0.7.0
    10: Outliner v4.1.1
    11: Obsidian42 - BRAT v0.6.36
    12: obsidian markmind v1.6.4
    13: Settings Search v1.2.0
    14: Style Settings v0.4.12
    15: Table Enhancer v0.2.2
    16: Table Generator v1.3.1
    17: Tag Wrangler v0.5.5
    18: Templater v1.16.0
    19: Projects v1.3.0
    20: Dataview v0.5.47
    21: v1.0.4
    22: Excalidraw v1.8.4
    23: Hover Editor v0.11.8
    24: Kanban v1.5.1
    25: Link Favicons v1.8.1
    26: Media Extended v2.11.1
    27: Media Extended BiliBili Plugin v0.3.1
    28: DB Folder v3.0.1
    29: 增强编辑 v0.5.5
    30: Remotely Save v0.3.25
    31: Auto Card Link v1.1.1
    32: Force note view mode v1.1.1
    33: Latex Suite v1.6.8
    34: floating toc v2.2.5
    35: Automatically reveal active file v1.0.2
    36: Editing Toolbar v2.2.2
    37: Spaced Repetition v1.8.0
    38: Surfing v0.5.0
    39: Annotator v0.2.8
    40: Omnisearch v1.9.0
    41: CardBoard v0.6.7
    42: Linter v1.9.1
    43: Advanced Slides v1.19.0
    44: Mousewheel Image zoom v1.0.13
    45: Markdown Table Editor v0.3.1
    46: Image auto upload Plugin v2.9.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I think this can be a common use case, just like a folder with only one file in it or even an empty folder. Hope cavas will support it.

I can’t reproduce. Post a screen recording of this happening in the sandbox vault. Thanks.

I can’t reproduce it, too. But I do reproduce it for several times yesterday. I will add some information when it occurs again. Thanks.

I had a canvas file deletion, but did not delete any cards. Created a canvas 2 days ago. Went to open it today, and it wasn’t there. Did a file search and went through my trash can. Not there. Was able to find the file in a Time Machine back up, so I know I am not crazy.

I don’t know how to recreate the bug. It was just gone. I last used the canvas 2 days ago, and it disappeared the next day. A day I did not open it. It was there in a morning Time Machine back up, but gone by the evening. I was using Obsidian, just not using that (or any other) canvas.

macOS 13.1
Obsidian v 1.1.8

I can’t reproduce. I need reproducible steps in a clean vault.

I got the same behavior, my canvas files got deleted. In my case this happen after opening my vault in an outdated obsidian app.

  1. I created the canvas in my work laptop
  2. I open the obisidan app in my personal lap with an app outdated. The canvas files disappear here.
  3. When I joined in my work lap those files gone.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.