Cant see why I have this Dataview error

Things I have tried

This is what I have set up in a doc.

doctype: Ur
date: 13-10-2022
dueDate:
Client:
Developer:

This is the dataview I have set up

table date, Client, Developer, dueDate
Where doctype ="Ur" 

and this is the result.

image

Why is it not showing the doc with the ur doctype? If anyone can help please, it would be much appreciated.

What I’m trying to do

Hi @gjjh25 , it seems likely that there might be an issue with how you’ve set up your fields. There are two ways to set up fields for Dataview to use.

The first is as fields in the YAML front matter, which is separated by two sets of three dashes and uses a single colon to separate field from value, e.g.:

---
doctype: Ur
date: 2022-10-13
---

Text of your document...

The other way is via Dataview inline fields, which are in the body of the page and use two colons to separate field from value, e.g.:

Text of your document...

doctype:: Ur
date:: 2022-10-13

More text of your document...

Also note that Dataview only understands fields in YYYY-MM-DD format.

I hope this helps! If it still doesn’t work, please post the full contents of one of your pages so we can get a better idea of what’s going on.

Craig

Thanks Craig that was a help.

i had ``` instead of —, it works now.

1 Like

So this is my code to view the results

table date, Client, Developer, dueDate
Where doctype ="Ur" 

But it is also including the template, what would I add to exclude the template from the results?

Many ways:

  • read the docs;
  • using FROM to filter the source (folder, tag, file);
  • or using WHERE.

thank you