Can't Open Spreadsheet Files

I’ve added a couple of spreadsheet files into my vault.

And every time I try to open them, it tells me the file is read-only and I can’t edit it.

But if I open the same file in the explorer, it opens normally.

I tried changing the properties >> read only settings, but they are already set to the highest privilege, i.e. read & write access.

And couldn’t find other similar threads in google, nor the forum.

Any ideas? Thanks a lot!!

Randomly found a solution myself.

In LibreCalc:

Tools → Options → Advanced → Button: Open Expert Configuration

Search for “UseLocking”. It should be “true” by default.

Set it to “false” by double-clicking.


Not sure if this is a minor or a major security transgression, but it does fix the issue.

That probably refers to file locking, which prevents other apps from changing a file after the first app has opened it. I wouldn’t expect Obsidian to set a lock on the file, but maybe it is somehow? This probably isn’t a pressing issue and might be Linux-distro–specific, but if you’re up for it I’d like to try to figure out what’s happening.

Thanks a lot for that!

As I mentioned above, I found a solution by disabling the UseLocking in LIbreOffice.

Not sure what else could be done. This seems to fix the issue.

I’m on Linux/PopOS (deb-based).

I know you worked around the problem, I was just hoping to find out if Obsidian is doing something wrong so the root of the problem can potentially be eliminated. You generally want to keep the setting you changed at its original setting.

I just tested with LibreOffice on Mac and don’t see the same problem, and the locking setting is set to “true”, so if Obsidian is doing something wrong it’s platform-specific.

Yeah, then it seems to be Linux-distro-specific.

I’m more than happy to troubleshoot further to provide you with more clarity.

Just let me know what I should do.


Before I tested on Mac I looked into file locking a bit and troubleshooting might be beyond me. :sweat_smile:

But if you want you could file what you’re seeing in a bug report.

Ahh, I see, okay great.

But are you sure it’s a problem with Obsidian or with LibreOffice itself, and the way it handles 3rd-party app access on Linux?

I’m definitely not an expert on this stuff, but it seems like Obsidian is setting a lock on the file when it shouldn’t, or if it should set it then it’s not releasing the lock when it should.

I see, ok great, thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.