Cant open ExcaliBrain. The Command just does nothing

What I’m trying to do

I am trying to open Excalibrain. I have a note opened and open the command pallette. Then i choose “ExaliBrain: ExcaliBrain normal”. Nothing happened. When i choose “Excalibrain: ExcaliBrain popout window” instead, it opens a new normal obsidian window with one tab without a note opened.

Things I have tried

Ive tried to update Obsidian (but im on the newest version) and to update the three addons Excalibrain, Excalidraw, Dataview, but it didnt help.

Ive tried to disable all themes, snippets and addons except Excalibrain, Excalidraw and Dataview and restarted obsidian after that, but it still did not work.

Ive tried to open the sandbox vault and installed the three addons. There everything worked fine!

Any ideas whats going on?

Heres my debug info:

Obsidian version: v1.3.7
Installer version: v1.3.7
Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:14:54 PDT 2022; root:xnu-8792.41.9~2/RELEASE_X86_64 22.1.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 1
Restricted mode: off
Plugins installed: 29
Plugins enabled: 3
1: ExcaliBrain v0.2.8
2: Excalidraw v1.9.17
3: Dataview v0.5.56

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I appreciate any ideas on this!

I actually solved the problem.

First i tried to make another new vault, installed excalidraw, excalibrain and dataview.
Then i created a test note to see if it works. It did work.

Then i copied all the files from my main vault into that vault.
I got asked whether i want to replace the I said yes.

After that it didnt work in that new vault anymore.

So i thougt the was the problem.

So i went to my main vault, deleted the in the Finder (file explorer on windows) and tried again.

Then it worked. Apparently the file was faulty.

I wanna leave this here, in case someone else experiences the same problem. Deleting the might be the solution.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.