Can't link to files with pipe "|" in the filename

Steps to reproduce

  1. Create a note with the pipe character “|” in the file name. This file will be saved properly, as that is a legal filename character, at least on MacOS
  2. In another note, create a link to the first note. The link will be created using the filename, including the pipe character
  3. Try to navigate to the first note using the newly created link. This will fail and instead create another note using a portion of the original filename.

Expected result

Expected the link to work properly and navigate to the source file. Or at bare minimum an error/warning while creating the note and/or link.

Actual result

Link is created but doesn’t navigate to the desired location.


  • Operating system: MacOS 10.15.4
  • Obsidian version: 0.6.0
  • Using custom CSS: No

1 Like

If you tried to create such a note, it should tell you that it’s not allowed. We do this so that notes can be accessed cross-platform. Is it not giving you an error when you type in the | character?


Oh interesting… no it did not give me that error initially. I just tried it again, I think what is happening is if you type the pipe then you get the error message as you indicated, but if you paste the title (which I did initially) then you don’t get the error and the file is saved with the pipe, resulting in the broken link.

Interesting. I’ve added a second level check in v0.6.0 for when the rename does happen but I just found a mistake that may have let the rename go through in some situations. Will be fully prevented in the next version!

1 Like

Awesome! Thank you! And thanks for responding so quickly too!

1 Like