Can't enable Overwrite Mode and/or I'm stuck in Insert mode

Things I have tried

I’ve searched the forums and crawled through the basic Obsidian options. I’ve looked through the Windows 11 options, and through Windows 11 forums as well, in case it was an OS-level issue.

What I’m trying to do

There are some tables in my notes that I’d like to be able to edit without having to delete spaces (so that the table remains aligned correctly)

The Insert key would naturally allow for this: I could turn on Overwrite mode to add text as needed, and turn on Insert mode if the cell’s contents become too large.

Currently, though, it seems like the Insert button isn’t working, and I can’t find any options or forum posts that explain how to enable it in Obsidian.

I’m using Windows 11 Home currently, and I’m aware that on this version of Windows, the Insert key doesn’t do anything unless the program you’re currently in has an option to enable it.

Have I overlooked an option to enable this? Is this something that should be added as a feature request? Is there maybe a community plugin that can allow for this (I’m currently using Table Extended since my table-related needs fairly complex. So, I can’t use Advanced Tables, even though this would actually solve the problem in a different way, as the two plugins are not compatible.)

This would (maybe surprisingly?) drastically improve my workflow, considering how much I edit tables.

Thank you in advance to anyone that can help!

Ah, first post here, didn’t realize how the “Things I have tried” and “What I’m trying to do” sections worked. Apologies!