Can't Close Find/Replace Bar

Steps to reproduce

  1. Open the Find/Replace bar. (on Mac I did option-command-F)
  2. Use the bar or don’t, the issue happens either way.
  3. In top right of Find/Replace bar, click on little X to “Exit search”.
  4. The bar does not go away.
  5. I also tried the ESC key. That didn’t work either.
  6. I had to quit Obsidian and restart, then the bar was gone.

Expected result

I expected the Find/Replace bar to go away.

Actual result

The Find/Replace bar stays right there.


  • Operating system: Mac OS 11.6
  • Debug info:
    Obsidian version: v0.14.15
    Installer version: v0.14.15
    Operating system: Darwin Kernel Version 20.6.0: Mon Aug 30 06:12:20 PDT 2021; root:xnu-7195.141.6~3/RELEASE_ARM64_T8101 20.6.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: on
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Safe mode: on


Additional information

I can’t reproduce this. Can you post a screen recording of this happening in the sandbox vault?

How do I access the sandbox vault? (Sorry, I’m new here. I poked around but haven’t found it yet.)

the ? in the lower left and then click open sandbox

Oh! I was looking in the Forum. :woman_facepalming:

Ok, in the Sandbox vault I created a note “Screen Recording re. Find-Replace Bar” with the video. Is that all I need to do?

does it happen in the sandbox vault?

I am very confused. I thought you wanted me to post a screen recording of it happening on my computer, into the sandbox vault. (I didn’t understand how you would be able to see the same sandbox vault that I see. :woman_shrugging:t2:)

It doesn’t happen in the sandbox vault, only in my personal vault.

How do I post any video recording to you? When I tried via the Forum, it said it did not accept video files.

I’ve noticed other weird glitches as well. Is it possible that my vault or application is somehow corrupt?

I just tried trashing the preferences file (md.obsidian.plist) - that didn’t fix it.

If it doesn’t happen in the sandbox vault, some plugins or theme are creating this problem

I don’t have any plugins or themes. I literally just started using Obsidian a few days ago! I don’t even know how to install plugins or themes yet. I’m using Light mode, if that makes any difference! :rofl: Probably not.

Maybe I’ll delete the application, re-download it and try over. Could that help? Any other suggestions?

That’s very odd. I don’t know.

I deleted Obsidian, re-downloaded, installed, created an empty vault. Problem happened in the first note.

Can this be escalated somehow?

It also happened when I switched users on my Mac. I logged into Guest User, same problem.

One thing you can try:

  1. Open the developer console. On Mac, Cmd-Shift-i or there is a menu item somewhere.
  2. In those tabs, click on “Console”. That is where errors show up.

When you click the little X, do you see any errors print out in that output? If so, can you paste them here?

Do you mean the Console application, in the Utilities folder on the Mac?
Mine looks different than the image you provided (see below).

I did not see messages come up when I clicked on the X.

No, I mean in Obsidian.

@WhiteNoise I can reproduce this in 0.15.4 (0.14.15) on Windows 10.

rona has “Legacy Editor” turned on. If I turn on Legacy Editor, I also can’t close the search modal. Reproducible in the sandbox vault too.

@rona I suggest you turn OFF “Use legacy editor” in the editor preferences. Especially if you’re new to Obsidian, I suggest you give the new editor a try.

The new editor means that preview is visible in edit mode, right? I don’t care for that, I like them separate. At least now I know that’s the culprit. But still - I’d like to escalate that bug, b/c it shouldn’t be happening w/legacy editor either, right?

There is no “escalating bugs” - this is a forum for community support. It might get fixed soon, and you might have to wait a while.

Yeah the new editor is live preview. But in the new Live Preview mode, you can click on options and choose “Toggle Live Preview / Source mode”. Source mode is where you just see your code. The Legacy Editor won’t always be supported.

If you moved your vault, you just have to open it again. Open the vault switcher. Click “Open”, go open your vault at the new location.

The legacy editor is going to be removed soon. You can use the new editor in “source mode”.