Cannot upgrade Obsidian from 0.12.12 to 0.15.9 in windows

I saw a post that seemed like this but there didn’t seem to be a solution. Anyone got one? Basically, if I try to upgrade, it says that Obsidian is already open, though it is not. I tried restarting the computer and no dice.

Are you trying to update from within Obsidian settings? Since your version is 0.12.12, you should download the installer and try again if you haven’t.

1 Like

Yup, as jwl said, reinstall from the website. And since you are upgrading from such an old version, I highly recommend you backup your vault before you do, just in case. (Never mind just in case. You should always backup.)

Yeah I did that and it tells me when it’s installing that obsidian is already open. I even tried restarting.

I checked the task list and it doesn’t look like obsidian is already running.

Oh well that’s different. Strange.

Just to double check, by “task list”, do you mean the list of apps and background processes in “task manager”? And “background processes” is shown and visible?

What version of Windows?

What if you uninstall the old version first? Your vault will remain intact, though you might have to add it to the list of vaults again, later. Though of course, do backup to be safe.