Cannot install on Ubuntu via AppImage

What I’m trying to do

I am trying to install Obsidian on Ubuntu 23.04 with AppImage but I get the following errors:

./Obsidian-1.4.14.AppImage
2023-10-03 10:34:43 Loading main app package /tmp/.mount_ObsidiQlTZGw/resources/obsidian.asar
Error: ENOENT: no such file or directory, open ‘/home/joelrudsberg/.config/obsidian/obsidian.json’
at Object.openSync (node:fs:601:3)
at Object.func [as openSync] (node:electron/js2c/asar_bundle:2:1869)
at Object.readFileSync (node:fs:469:35)
at t.readFileSync (node:electron/js2c/asar_bundle:2:9212)
at /tmp/.mount_ObsidiQlTZGw/resources/obsidian.asar/main.js:1:3390
at R (/tmp/.mount_ObsidiQlTZGw/resources/obsidian.asar/main.js:1:2117)
at E (/tmp/.mount_ObsidiQlTZGw/resources/obsidian.asar/main.js:1:3371)
at module.exports (/tmp/.mount_ObsidiQlTZGw/resources/obsidian.asar/main.js:6:3411)
at loadApp (/tmp/.mount_ObsidiQlTZGw/resources/app.asar/main.js:294:3)
at Object. (/tmp/.mount_ObsidiQlTZGw/resources/app.asar/main.js:446:12) {
errno: -2,
syscall: ‘open’,
code: ‘ENOENT’,
path: ‘/home/joelrudsberg/.config/obsidian/obsidian.json’
}
2023-10-03 10:34:43 Checking for update using Github
2023-10-03 10:34:44 Success.
2023-10-03 10:34:44 Latest version is 1.4.14
2023-10-03 10:34:44 App is up to date.
[31303:1003/123448.035750:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 1 times!
[31303:1003/123458.009352:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 2 times!
[31303:1003/123458.011858:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 3 times!

Before I of course set the file as executable. Thanks

Things I have tried

Tried creating empty folder and file but that leads to other issues.

There are issues with running appimages on that version of Ubuntu. Setting the file permissions doesnt help with this. The cure is to install fuse2. Not sure if this is your issue here, but worth a try.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.