Cannot edit nested properties in Preview mode

Steps to reproduce

Create a metadata file with nested properties, like this:

 thing1: value1
 thing2: value2
another:  value3

Expected result

I want to change various property values in Preview mode as easily as before.
Strangely, some can be changed, some can’t. It’s confusing, arbitrary and not helpful.
I want to created nested properties in Preview mode. This seems now to be impossible. The choices of properties do not even include this as an option. It seems unsupported, or at best in “ugly stepsister” mode.

Actual result

It is displayed like this
value1 and value2 cannot be edited. value3 can be edited. Confusing. Broken.


Obsidian version: v1.4.2
Installer version: v1.3.5
Operating system: Darwin Kernel Version 22.5.0: Thu Jun 8 22:22:20 PDT 2023; root:xnu-8796.121.3~7/RELEASE_ARM64_T6000 22.5.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 0
Plugins enabled: 0


Additional information

So far Properties just seem to be in my way, adding busy work and giving me no new abilities or insights into my vault. I can’t ignore them and they interrupt my work flow. I hope they can be made so they are usable in the future.


I think nested YAML are not supported within Properties :thinking:

But you could add your voice here:


Thank you. I view this as a bug in the new YAML display, not a feature request, because a week ago, nested properties used to work fine and be easy to edit, now it’s a big cluster-fluke. This strange new point-and-click YAML interface is absolutely awful in Preview mode, much harder to use and impossible to just type into. It appears to me that the developers are trying to discourage typing text in the metadata and force the use of menus to insert text. Why, just why?
You can edit a few things, but mostly not. And here is a whole class of metadata that worked fine and now is completely unusable in Preview mode.
Anyhow, thanks for your reply and for pointing out the feature request. Seems odd to request a “new” feature that was present a week ago. :slight_smile:


Well, it is a beta, not the stable release. (Tho that doesn’t rule out that it could have been a bug.)


I ran into the same issue. I have not even been able to find a way to disable the properties feature entirely (disabling the core plugin doesn’t even do it). Not a fan of this feature at all; plain text YAML worked just fine.

1 Like

I still don’t understand what is “better” at all about it. It requires more clicking and typing to do any given task than it did before. Is it fancier? Not worth it if it’s just for chrome.

I’m having the same issue. I’ve used nested YAML since I started with Obsidian, and now I’m forced to switch. To be honest, nested YAML isn’t as useful as I thought it might be, but still I’d like to have the choice. I’m also having trouble seeing the benefit of properties vs traditional frontmatter. It just seems like a graphical wrapper to the YAML that I was already using, but with broken parts. I’d like to have the option to turn it off.

1 Like

This is some of the thinking behind the new properties setup: