Can’t get YAML to work in iPad

Things I have tried

I’ll admit, I’m REALLY new to Obsidian… but I am LOVING the possibilities of it.

I’ve tried different ways of inserting and formatting the 3 dashes “- - -“. I’ve made sure they start on the first line. I’ve tried putting in this….
- - -
Foods: [Apple, Orange, Pineapple] pear
Just some other junk
- - -

And I don’t get a YAML error at all.

Plus, when I put it in correctly….

 - - - 
   Foods: [Apple, Orange, Pineapple]
 - - - 

it doesn’t change to a YAML block.

I’ve watched YouTube videos and done web searches and I can’t find what I’m missing.

What I’m trying to do

At this point… I’m just trying to get YAML to work from my iPad so I can start using DataViewer.

Oh… I supposed I should mention… I’m also trying to do a “mobile only” workflow… where the iPad is my main compute device. I have a MacBook and could go to that… but it still doesn’t solve the problem.

Thanks for the help and listening… and putting up with my first post here.

There shouldn’t be any spaces on the top/bottom lines, just dashes. I don’t think the indent is valid either.

OK…

So this is what I’ve found out…

the “dashes” on the iPad… or my iPad, at least, are different. (Not sure how that works)

When I went to YAML front matter and copied / pasted the example from there… it worked… and the dashes looked different.

I then deleted the first line and tried every “dash” I could find on the iPad keyboard and couldn’t get the YAML to come back. Not until I re-pasted the dashes from the example.

I’ve also noticed… that if I type 3 dashes, anywhere else, it does not give me the horizontal line… however, if I include spaces or type 3 underscores it does.

I’m thinking something is up with iPad’s keyboard and dashes.

1 Like

Try turning Smart Punctuation off in keyboard settings.

2 Likes

Stevelw… you are my hero!!

I mean, I’m an IT guy and claim to be an Apple “Fan Boy” and I didn’t even know of that option!

Thank you so very much! You have made my day!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.