Can’t bind hotkey to ctrl+shift+0

Steps to reproduce

  1. Go to settings > Hotkeys
  2. Try to bind a command to this hotkey: ctrl+shift+0

Nothing happened, no error message, and the hotkey stays unchanged.
It’s weird that it works for ctrl+0

Did you follow the troubleshooting guide? [Y]

Also tried in the sandbox vault

Expected result

Being able to use this hotkey to run commands.

Actual result

Nothing happen

Environment

SYSTEM INFO:
	Obsidian version: v1.5.12
	Installer version: v1.5.3
	Operating system: Windows 10 Pro 10.0.19045
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: off
	Live preview: on
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 0
	Plugins enabled: 0

RECOMMENDATIONS:
	none

Additional information

I want to reproduce Notion and other editor shortcuts to change text formating (different heading levels, bullet list, checklist, and reset formatting). They usually take the form of a ctrl+shit+number hotkey.