Can not open Obsidian in except in safe mode

Things I have tried

What I’m trying to do

Dear all,
In the recent few days, when I open Obsidian, it shows “An error occurs while loading obsidian, TypeError: can not read properties of undefined (reading url)”. I can only open obsidian in safe mode, therefore I can not use all the plugins.
It was OK when I use Obsidian in version 0.14.X.
Is there any way to fix the problem?
Thanks a lot.

Maybe you need to update your plugins. Can you paste your “Show debug info”?

Hello rigmarole,
I updated all the plugins, but the problem still exists.
The debug info as below:
SYSTEM INFO:
Obsidian version: v0.15.9
Installer version: v0.14.15
Operating system: Windows 10 Pro 10.0.19044
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: Blue Topaz
Snippets enabled: 0
Restricted mode: off
Plugins installed: 27
Plugins enabled: 26
1: Calendar v1.5.10
2: File Explorer Note Count v1.2.0
3: Dataview v0.5.41
4: Annotator v0.2.4
5: Kanban v1.3.15
6: Advanced Tables v0.17.3
7: Excalidraw v1.7.9
8: Ozan’s Image in Editor Plugin v2.1.1
9: Tag Wrangler v0.5.3
10: cMenu v1.1.2
11: Various Complements v7.1.1
12: Recent Files v1.3.3
13: Emoji Toolbar v0.3.1
14: Enhancing Mindmap v0.2.3
15: Mind Map v1.1.0
16: Style Settings v0.4.10
17: Code Block Enhancer v1.0.5
18: Easy Typing v4.0.6
19: Editor Syntax Highlight v0.1.3
20: Dictionary v2.21.1
21: Templater v1.12.0
22: Outliner v2.3.0
23: Local images v0.14.2
24: proxy github v1.15.0
25: BookNote v0.2.4
26: Markdown prettifier v0.1.3

RECOMMENDATIONS:
Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I concern about the plugin BookNote, which is really helpful but not release in Obsidian community.

First, please try to download the latest installer from the website, and reinstall.

I’m not sure, because I’m up to date. But I’m pretty sure you should be seeing a warning in “About” that it is time to update your installer. There are major updates that can’t be auto-installed by the update button, and your installer is out of date.

After you do, you might have to update plugins again. (I’m not sure.)

If that still doesn’t work, maybe it is a plugin. Then I suggest turning off and back on plugins to isolate which one might be causing the problem.