Callouts do not auto-pair quote ticks after the first time

Steps to reproduce

Start to write a block quote. Use " and first one will be auto-paired. Write some text inside and write something else to the outside. When you press " again, it will not auto-pair.

Expected result

It should auto-pair every time. It should not just auto-pair one time.

Actual result

It only auto-pairs for the first one. After the first pair of quote marks, it only adds one quote mark when you press it.


Obsidian version: v1.0.3
Installer version: v1.0.3
Operating system: #24-Ubuntu SMP PREEMPT_DYNAMIC Fri Oct 14 15:39:57 UTC 2022 5.19.0-23-generic
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 3
Restricted mode: off
Plugins installed: 5
Plugins enabled: 5
1: Calendar v1.5.10
2: Obsidian Git v2.10.0
3: Vault Statistics v0.1.3
4: Advanced Tables v0.17.3
5: Dataview v0.5.47

Post a screen recording of this happening in the sandbox vault

1 Like

To be honest, I have no ways of screen recording on my computer and I am so far away from such things. But I tested it with the sandbox vault and it still not auto-pairs. The key thing here is, which I admittedly forgot to mention, this happens on the title of the block quote. Like:

[!Warning] “this is a test” "

I am sorry that I am unable to provide the screen recording for you but I have tested it on a sandbox vault and it still happens.

I still don’t quite understand the sequence of actions that you are doing.

It may not be a bug because autopair needs spaces between words

1 Like

Ok I can reproduce.

1 Like

I have just noticed something different. I need a couple minutes because this time, it worked. But if I do it in a certain way, it does not auto-pair. I am trying to figure out what is different.

For example, with this text, it works:

I think I found the problem. If you start the title with the quote marks and then try to add another one to the rest of the title, it won’t auto-pair.


If you type anything in the title before the quotes, it will auto-pair.


Hope this is clear for you. Thank you for going through this with me.