Calendar permission is not requested on MacOS (Ventura)

I’m in struggle street a little bit here.

I’ve tried installing the latest package from the repo above and get the below when trying to install

CleanShot 2022-12-01 at 13.31.06

Obviously there’s an issue here, not that I know more than that. When I create a new note I see the following error

CleanShot 2022-12-01 at 13.32.33

For Reference I’m running Ventura on a 2021 M1 Air

@gregb the install command uses python 2. This is no longer automatically installed with MacOS. Install Python2 from the Python website and you’ll be able to execute that script.

I have the same problem, but the easiest way to do the job is the following:

  • Make a bash script (ical.sh) containing your command icalBuddy and saving the output in a text file (ical.txt)
  • Run this script every minute/hour/… in order to keep update your calendar state
  • In Templater simply replace your icalBuddy command by /bin/cat ical.txt

That’s it! :slight_smile:

Precisions: the shell command crontab -e enables to run stuffs every minute/hour/etc. But if cron is not allowed to use calendar it will also raise an error: no calendar. In my settings Automator is allowed to use it, therefore I wrote a process in Automator running the shell script involving icalbuddy command, then saved it as an App (ical.app) and used cron to schedule the execution. In crontab -e I have inserted this line: * * * * * open /path/ical.app

To solve the problem for cron follow these links: macOS Catalina : No Calendars Error - Launchd · Issue #28 · ali-rantakari/icalBuddy · GitHub

I’ve verified the entitlement has been added to Obsidian v1.1.9 and the issue has been resolved.

This is still broken for me
Works fine in terminal but still get the ‘No calendars’ error in console when running through templater
Already updated to v1.1.9

Just a quick note for those who are still having this issue - I updated to the v1.1.9 installer, and it prompted me for calendar access when I used my script(s) to run icalBuddy. So if you haven’t updated your installer (look at Options->About) it is worth trying.