Button template insertion briefly flashes the message and erases it

What I’m trying to do

I’m trying to create a button that would prepend a template to my note at a specific line. I have a “Standups” note, and I want to add a button that would add a new “day” to it. Here’s how it looks:
image

The code for the button is:

name Add a Day
type line(8) template
action StandupDay
templater true

The problem is that the template flashes and immediately gets deleted upon clicking the button:
ezgif.com-video-to-gif

The template is as follows:

###### {{date}}
Plans
- <% tp.file.cursor() %>
Problems
- 

My vault looks like this (truncated):

    ├───.obsidian
    │   └───plugins
    │       ├───advanced-cursors
    │       ├───buttons
    │       ├───calendar
    │       ├───cm-editor-syntax-highlight-obsidian
    │       ├───dataview
    │       ├───obsidian-excalidraw-plugin
    │       ├───oz-image-plugin
    │       ├───recent-files-obsidian
    │       ├───table-editor-obsidian
    │       └───templater-obsidian
   ├───Excalidraw
    │   └───.obsidian
    │       └───plugins
    │           ├───advanced-cursors
    │           ├───calendar
    │           ├───cm-editor-syntax-highlight-obsidian
    │           ├───dataview
    │           ├───nldates-obsidian
    │           ├───obsidian-excalidraw-plugin
    │           ├───omnisearch
    │           ├───oz-image-plugin
    │           ├───recent-files-obsidian
    │           └───table-editor-obsidian
    ├───Templates
    │       StandupDay.md
    └───Tom
        ├───.obsidian
        ├───.trash
        ├───Hepta
        │       Standups.md

I’m running Obsidian on Windows 11, with Obsidian version 1.3.7.

Things I have tried

I’ve also tried using the button without the templater true parameters. Initially it said that the template is not found. I removed spaces from the template name, so now it kind of works without Templater, but I’d like to extend the template with some advanced features that only Templater offers.

I thought maybe it’s the Syncthing issue that’s syncing my vault across devices, but it also happens when I turn off Syncthing.

My Android device says "Couldn’t find the specified template, please check and try again.

1 Like

Got the same problem, tried to change set cursor at a particular line first or even set line in the button, same result. Briefly pops up in its correct configuration of the templater, and then vanishes.
Ive got a hunch that this may be something due to the sync options maybe?

Im using iCloud on windows and Iphone, same result on both.

I also first thought it’s about sync, but it’s a bit weird because:

  • The template insertion works when I remove the templater True line
  • The flashing issue persists when I disable SyncThing/Synctrayzor
  • The same thing happens on Android

I first suspected maybe Templater uses another process to edit/save the note and perhaps that process lacks permissions, or something. But it also happens on Android which has a different file system, so I doubt that’s the issue.

I’d appreciate any thoughts on how to further debug this.

I’ve now switched to Obsidian Sync, and completely removed SyncThing from all my devices. The issue remains the same. Here’s a video showing the issue on 2 devices - Windows 11 on top, macOS on the bottom. Feel free to read the standup notes and what I fill my days with :joy:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.