Bug with keyboard layout in vim

Steps to reproduce

  1. Import the layout available here: GitHub Gist
  2. Go to the help vault (no plugins)
  3. activate vim mode
  4. make sure the keyboard layout is actually selected while now in obsidian help vault
  5. press ‘option+i‘ which should activate the search (as / starts file search in vim)
    and see that it inserts a slash before the active character [alternatively press option+n for tilde, which also inserts a tilde instead of changing the case of the character beneath the cursor]

Expected result

enter into vim search

Actual result

it inserts a backslash before the character one is on with the vim cursor (in normal mode)


  • Operating system: MacOS 11.5.1
  • Debug info:
    Obsidian version: v0.14.2
    Installer version: v0.14.2
    Operating system: Darwin Kernel Version 20.6.0: Wed Jun 23 00:26:27 PDT 2021; root:xnu-7195.141.2~5/RELEASE_ARM64_T8101 20.6.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: on


Additional information

I encounter the problem on mac (visible by the use of the option key) and I am not sure how the keyboard layout translates to windows machines. So maybe however wants to test this might want to do that on a Mac machine.

I am not gonna take this as a bug report. Moved to developer and api.

I saw it as a bug since different keyboard layouts (mine and the default Swiss German one off of which mine is based) do not work as intended with vim commands as the US layout does.

Closing this.

Keyboard remap was with .keyboard layout, not with the fundamental keycodes sent by the keyboard. I guess, the commands in obsidian are really bound to the keycodes. And the keycodes can only be changed with a custom layout built with for example qmk-software.