[Bug] Using spaces to indent works in Edit mode, but not in Preview mode

Platform

[X] iOS
[ ] Android

Obsidian Mobile version: 1.0.5


Four spaces in front of a paragraph creates a code block. However, three spaces nicely formats a paragraph, putting it in line with bulleted or blockquoted paragraphs. That is, it does in Edit mode. But in Preview mode, the indentation vanishes, leaving the paragraph aligned to the left.

This is because Markdown eliminates white space like this when it’s rendered. The best way to achieve the look you want is probably via style settings—i.e., CSS, or by installing a theme that gives you first-line-indent on paragraphs.

So there is just no way to indent text in this app?

I do not want every paragraph indented, just the ones I indent.

Well, I guess you’re going to say “use in-line CSS,” but that’s an incredibly inconvenient thing to do while I’m writing.

It’s because this is a markdown app. See e.g.,

I suspect that the easiest answer might be to write in bullets, using CSS to hide the bullets. (I think there’s a native hotkey toggle for it too, but only it hides indents in Live Preview, not Reading View.)

Yeah. Markdown’s just not house trained.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.