[BUG] URI to open second not working correctly - delayed operation

Steps to reproduce

Create/have 2 vaults
Open app
Open first vault
Call URI open action on second vault

  • no action performed

Click open vault button

  • app instantly switches to vault that was called in above URI request

Expected result

URI call should pen second vault

Actual result

URI call does not open second vault


  • Operating system: iOS
  • Obsidian version: Tested on obsidian 0.1.4, 1.0.0 & 1.0.2

Additional information


Please post mobile bugs in the mobile section.

Is this not the mobile section? Sorry, thought I had…

Can you paste the URLs you’re trying to use here?

Screenshot of the iOS Shortcuts used and a short video;

I can reproduce this.

A shortcut for testing:


1 Like

Same problem here(


This has changed in current insider build (1.0.4);

Still no immediate action seen when running shortcut
But, now clicking the open vault button performs as normal - doesn’t immediately open other vault.

I have this problem as well.
Makes it very hard to automate note taking and article archiving with Shortcuts.

Same problem.

Current version (1.05) still have this issue.

Same issue here, I can reproduce this on version 1.0.5 of obsidian on the app store.

I have found the cause of this issue and I will start working on a patch once the next mobile version has been released.


Steps to reproduce

On iOS:

  • Trigger an “open” url to change vault, eg obsidian://open?vault=MyVault (you can do this using the Open URL action in Shortcuts, for example. That’s how I do it and how I found this bug.). This will work first time, so if you’re in MyOtherVault, it’ll switch to MyVault.
  • Trigger it again for another vault name, to switch to MyOtherVault. It’ll stay in MyVault.
  • Try to manually change to MyOtherVault. Pressing the vault button in the sidebar will change the vault for you, to the vault requested in the deeplink.
  • The vault button won’t let you manually change a vault now until you kill the app. It’ll just keep triggering the deeplink.

Expected result

  1. The vault should always change automatically using the deeplink format above.
  2. The Vault button in the sidebar should always show the vault picker view.

Actual result

  • Using the url scheme to change vaults failed after the first time.
  • Using the Vault button in the sidebar just keeps triggering the failed url scheme deeplink rather than showing the vault picker.


  • Operating system: iOS 15.2
  • Debug info:
    Isn’t showing on the iOS command picker…

Additional information


I can confirm this. Seeing this as well.

1 Like

I just made an iOS shortcut today and I’m seeing this issue too!

1 Like

I am also seeing this issue.

1 Like

I am also experiencing this issue. If the Obsidian app is already running, then using obsidian://open?vault=MyVault to switch to a different vault will appear to do nothing, and I’ll remain in my current vault, viewing my current note.

As soon as I tap the vault switcher icon, it will very briefly flash the vault switcher screen and then automatically switch to the vault previously specified in the URL, and show me the last note I had been viewing from the specified vault.

From now on, every time I tap the vault switcher icon, it does the same thing, giving me no opportunity to select a different vault via the switcher screen.

However, if I run a different shortcut URL such as obsidian://open?vault=MyVault2, the same thing will happen. I will seem to remain in vault 1, but as soon as I tap the vault switcher icon, it will very briefly flash the vault switcher screen and then take me to my last viewed note in MyVault2. It will then remain stuck on MyVault2 until I either kill the app or run yet another shortcut URL to force it to switch to another vault (and remain stuck there).

I’m on the very latest public release of Obsidian mobile 1.1.0 (38) on iOS 15.3.1

I’m a paid user of the Sync service and I love Obsidian. But an annoying bug prevents me from using it effectively on Android.

Steps to reproduce:
– Create two vaults: A et B.
– Close Obsidian and open the URI obsidian://open?vault=A.
– The vault opens properly.
– Leave Obsidian running the background and open the URI obsidian://open?vault=B.
– Obsidian opens up but still shows vault A.
– Close Obsidian entirely and open again the URI obsidian://open?vault=B. This time around, Obsidian properly opens vault B.

– Opening a vault using a URI should switch to that vault, even if another vault is already open.

– Android 11 RKQ1.200826.002 (rom: MIUI 12.1.4 stable).
– Obsidian Android version 1.1.0 (38), API v0.13.24.


Seeing this issue on iPad as well.

1 Like