[BUG] Unable to paste text on iOS

I see an older thread about a similar issue was closed as having been fixed. Did the problem come back or is this something new?

4 Likes

I have issued a fix, but from reports it seems that it only fixed it for some people.
Unfortunately, I was not able to find a way to repro it on any of my devices again, so I am not really sure how to fix this. I will investigate more into this later.

In the meantime, the three-finger tap should bring up an alternative copy paste menu.

2 Likes

This is what I’m going with, pasting is very hit and miss with me.

still have this problem in version 1.0.

Most iOS users would probably benefit from learning the three-finger pinch gestures anyway. I retrained myself to “think in pinches” a few months ago and I am note much faster at editing and manipulating text on the iPhone and iPad.

The gestures are described here and the Tips app/the iPhone or iPad user manual in Books.

2 Likes

Yeah, this is a big issue I’m struggling with on my iPad Mini 5 (latest iOS).

I don’t know if this will help to reproduce the issue, but when I’m simply tapping on the screen, the paste menu doesn’t appear. But if I type a couple of characters, then press enter to move to the new line, then select the characters and the next line, and then tap on the selection area - it works again. Like so:

Needless to say, this is an extremely frustrating issue. I really hope you guys can find a way to fix it.

in the latest beta via testflight, you can add the paste button to the mobile toolbar. makes pasting much more smooth.

Steps to reproduce

Select text to copy or cut then select to paste that text elsewhere in an Obsidian document.

Expected result

The text will paste.

Actual result

The text will not paste from either a cut or copy. It is present in every theme I’ve tried, including the default theme so this is not a theme issue.

Environment

  • Operating system: iPad OS 14.7.1
  • Obsidian version: 1.0.4

Additional information

Update, this seems to be a sporadic problem. It occurs once in a while, not all of the time.

I can reproduce this… sometimes. It was happening to a vault of mine, and when I exited the vault and re-entered it, the problem went away. Something to investigate!

1 Like

Platform

[x] iOS
[ ] Android

Obsidian Mobile version: v1.0.4


  • copy content (text) from browser
  • open file in obsidian app
  • click the cursor
  • expecting menu to show up for paste content
  • but the menu does not show up.
  • however, double click which selects content in the obsidian file, triggers the menu for paste. But this will overwrite the selected content.
4 Likes

Can’t reproduce on version 1.0.4.

I am running the iOS 15 public beta, so maybe this is a iOS bug not an Obsidian one.

There’s some inconsistency for when the single-tap edit bar will show in Obsidian. It’s very hard to reproduce.

If you can’t get it to show, you can just use the other OS-level options:

  • three-finger pinch-out to paste
  • three-finger tap to bring up the global edit bar
3 Likes

Happens to me as well

I’ve found a mostly consistent way to reproduce this. When viewing a document that is more than one screen long, scroll to bottom and attempt to paste.

  1. Scroll to bottom
  2. Move cursor to last empty line in document
  3. Tap to right of the cursor

The desired behavior is that tapping the cursor should bring up the iOS context popover that displays the paste command. The actual behavior is that nothing happens.

I understand that there are other options for pasting on iOS but none of them can easily be done one handed. The preferred interaction would allow pasting text using just a thumb on the screen.

1 Like

Interesting. I wonder if there’s something about the zone beyond the last line that causes iOS to not recognize it as a text field…

I didn’t do extensive testing but I perform this action enough that it is extremely annoying. My report is mostly what I would do when appending clipboard to a note. Unfortunately the Templater function to insert clipboard does not work with iOS or I would use that as a keyboard button.

It’s understandably frustrating.

In the meantime, maybe a shortcut would work? Appending the contents of the clipboard to a designated file and then opening that file should be pretty easy.

it gets worse for me.
No matter what time,which file…
The same issue happens to me ALWAYS.

Hope it can be fixed soon.

ios
v1.0.4

Have you used the pinching gesture? I find it more reliable across the entire OS.

1 Like