[Bug] Text editing gets corrupted sometimes on Android

Text editing gets corrupted sometimes on Android and I have to reopen page or even force-close and restart app. For Obsidian to get back to normal.

If you need I can try to catch exect couses and provide more info.

As of now I think it is something with special blocks like links/checkboxes/tags etc.
And may be with Google Keyboard.

7 Likes

(Moved to Mobile and labeled as bug.)

2 Likes

Hi, I’ve also experienced this issue. In the Android Obsidian app (v1.4.1 on mobile), my attempts at typing cause the keyboard to pop in and out, often corrupting the text in my files while in editing mode. This has prevented me from using the app for editing while mobile whatsoever, and appears to occur in both existing files and new files without any plugins.

On mobile I have no custom themes and have attempted this with my sole custom plug-in, dataview, turned off. I’m presently on mobile, but i have a recording of this glitch and can upload it when I get to a place with stable wifi.

In the time i opened the app to get screenshots of this glitch, i had significant data corruption, which I’ve been able to remove on desktop mode, but obviously I’d like to be able to use the app in both mobile and desktop modes. You can find these screenshots below:




I hope that something can be done about this as I’m an avid user of Obsidian for note-taking and I’d rather not have to rely on only my laptop for notetaking

8 Likes

Bumped. I’m currently facing an identical issue. Obsidian version 1.4.1 (83), on Samsung Fold 4 OneUI 5.0.

Did you manage to have the issue resolved?

2 Likes

Just started happening to me as well after the OneUl 5.0 update on the Tab S7+, exactly the same issue as OP. App’s completely unusable on the tablet.

2 Likes

Getting Exactly the same thing when trying to edit on mobile.
I seem to be able to read things fine, but note making, taking / editing is a no no.
Android 13, Obsidian Mobile v1.4.1, Samsung Galaxy S20+ 5G

1 Like

The same thing has been happening to me on my Samsung Galaxy S7 Tablet. One UI version 5.0, Android version 13, Obsidian version 1.3.2

1 Like

On Samsung this is caused by Samsung keyboard predictive text function. Either disable it or use Gboard.

4 Likes

I can confirm that the workaround provided above works for the issue reported. Of course this does mean you lose the predicitive text capabilitites of your modile device so as a workaround that’s fine, but not a long term solution.

3 Likes

I’m getting this on a Samsung Tab S7FE also, but it seems to be a problem with both the Samsung keyboard and Gboard. I mistakenly posted a bunch of comments about it at this other issue instead.

Disabling “Predictive text” (and “Suggest emojis” and “Suggest stickers while typing”) seems to make the Samsung Keyboard + Live Preview editor combination functional for me again

However, this is certainly a serious bug that should be fixed soon. I did lose most of a note to this, probably because the bug might also delete children of folded bullets.

3 Likes

Glad to hear that you were able to source your issue @tomsb !

One thing that I used to restore older versions that had been corrupted with null characters was to use the “View Sync Version History”, and restore the last synced version that hadn’t been corrupted. I’m not sure if this works for non-Sync users, and perhaps you’ve already attempted this, but it’s what worked for me.

Definitely agree though, this is a serious bug that basically renders Obsidian useless on Android and needs to be fixed ASAP.

2 Likes

Same issues here, It happens on both my Samsung phone and tablet - s20fe & S8+. It happens with both samsung and gboard keyboard (I also sometimes use swiftkey). It’s been getting progressively worse issue over the last few months now and all seems related. At first it it was just suddenly being unable to add new lines to a note. Then later I’d often end up with a cursor where I could type text but was unable to create new lines, and when I’d leave in any way (eg go to home, switch note) and return any text for that line was gone. So that occurred pretty frequently, and was rather annoying, but resetting the app usually fixed it.
Same setup, no changes. Suddenly started doing the obj inserts around November. I received all the different inserted OBJ buttons, dots etc the OP displayed. The unpredictability of the corruption made mobile unusable - can’t spend one’s life monitoring for files to version revert.
Turning off predictive text works, but personally doing that is more feasible on the tablet.
=/

2 Likes

+1. I am also experiencing the same issue

Me and my boyfriend also report this issue. Both devices are on Android 13, running the latest One UI (he has a Galaxy Z Flip 3, I have a Galaxy Tab S6 Lite). This doesn’t happen on my Kyocera DuraForce Pro 2 (running Android 10)

Haven’t made moves to downgrade Obsidian and I’m not keen on playing with Odin to downgrade his phone or my tablet, lol. Sounds like this bug is localized to Samsung devices???

Edit: I was also using a physical Bluetooth keyboard. Boyfriend was using Gboard with autocorrect off, I believe.

When I add a bulletted list the bullets are there for a few seconds then disappear. Then suddenlybthe whole list is gone and replaced by red and white dots

2 Likes
2 Likes

+1. I am also experiencing the same issue

1 Like

Checking in to report the same exact issue. Disabling predictive text did work, but would prefer a real bug fix.

This is a massive data corruption issue. it has trashed most of my documents. It was first reported in Aug 22, five months ago. i know this is an OSS project, but this basically corrupts our Obsidian data and renders the tool useless. Is there any way we can get some resources and priority on this? the workarounds proposed are not working for me.

2 Likes

+1 i am also facing this issue.
i thought it was of syncing problem and try to debug there wasting so much time with no luck :smiling_face_with_tear: