[bug] Open Vault TypeError Symbol.asynclterator is not defined

Please add [Bug] or [Feature] to your post title, then delete this line.


[ ] iOS
[ x ] Android

Obsidian Mobile version: v0.0.xx

As the title says , the app display the error as follows:

We are gonna need more information.
v0.0.xx ?!?! We are currently on 1.0.4.
What is the vault location?
Also are you able to to create a new vault?
Did you enable any third party plugin?

Hi, Thanks for the reply.
I tried using version 1.0.2 and 1.0.4, they all got the same error. My android version is 7.1.1
I set the location of vault in my phone storage, location such as :/Phone Storage/ObsidianNote
I cannot create a new vault, it got the same error.
In my obsidian desktop, I enabled Advanced tables, Emoji Toolbar and Markdown Formatting Assistant, totally three community plugins.

The location you are reporting is very weird. Can you create a vault in the Obsidian default directory (Documents) ?

I choose the documents directory, the app show the location is :/storage/emulated/0/documents, but it still create failed, got the same error

when you choose a directory. A message flashes at the bottom of the screen for a few seconds. Can you take a screenshot of that?

Is your WebView package on Android up-to-date?

We believe that the issue is likely an old WebView version.

A message shows in the bottom is : content://com.android.externalstorage.documents/tree/...

I installed the newest version of android webview.

Still got same error.

I checked my phone’ system, I found out even I install the newest version of webview, it does not change the system’s webview version, but I installed chrome, and check the webview version of chrome, it is the newest version.
So I wonder if the obsidian can use the app Android System WebView rather than system’s default webview?

We have no idea how to help you. It’s possible that your device is still using the old and built in webview. We are sorry. I don’t think there’s anything we can do to help you.

What device do you have?

A chinese brand, smartisan.
Anyway thanks for the help.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.