[Bug] Numbered list changes to unordered list in Reading View


[x] iOS
[ ] Android

Obsidian Mobile version: 1.0.03

I noticed that a numbered list (unindented, first-level) seems to display as a bullet list in the Reading View on iOS platform.
I appreciate if anyone can shed some light on this issue.


which iOS version are you using exactly?

This may be a safari bug.

I’m having the same issue - iOS 15.6.1 on iPhone


Same problem here. iPadOS 16.1

16.1 here.

Steps to reproduce

Create several footnotes including an inline footnote and the corresponding explanations at the end of the note.

Expected result

In reading mode, I expect to see the explanations of the footnotes along with the corresponding reference number.

Actual result

In reading mode, footnotes are displayed at the end of the note as an unsorted list without the corresponding reference number. See attached screen shot.


  • Debug info:
    Operating system: ios 16.1 (Apple iPad)
    Obsidian version: 1.4.1 (83)
    API version: v1.0.3
    Login status: not logged in
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Minimal
    Snippets enabled: 5
    Restricted mode: off
    Plugins installed: 7
    Plugins enabled: 0

Additional information

Same result after updating my custom theme (Minimal Theme) and disabling all snippets and plug-ins.

1 Like

Please post a screenshot of same thing in reading mode.

@RoyRogers: The screenshot shows note in reading mode. However, hier is a screenshot of the note in live preview mode, just in case you wanted that.

Steps to reproduce

  • Have a list of numbered points in a note
  • View the same note on the Obsidian Mobile app

Expected result

I would expect to see a numbered list on Mobile, just like on Desktop

Actual result

On Mobile, when in Reading Mode, the Numbered List turns into a Bulleted List. I see the Numbered List as expected in Editing Mode.


  • Operating system: Windows 10
  • Debug info:

Obsidian version: v1.0.3
Installer version: v0.14.6
Operating system: Windows 10 Pro
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Deep Work
Snippets enabled: 1
Restricted mode: off
Plugins installed: 3
Plugins enabled: 2
1: Text Generator v0.0.10
2: Readwise Official v2.0.1

I am also using the latest version of the Obsidian iOS App.

Additional information

Example of Editing Mode on Mobile vs Reading Mode:

1 Like

Same here
iPadOS 16.1.1
Obsidian mobile v1.4.1

  • number lists will display as point form in Reading view

Confirmed same on iPad and iOS.

I noticed the same thing among my footnotes the other day. The references were not broken, though.

I have the same problem, any solution?

Might be something in the CSS. Was cycling through old themes and noticed the bug isn’t present in one (Obsidianite). Can’t stand that theme though, so I’d love a fix.

Mine did the same thing couple weeks ago where numbered list appeared as bullets…as of now, it’s not even displaying anything and it just looks like a paragraph. I tried using the original theme, disabling CSS snippets, and disabled community plugins but nothing worked. Everything works fine on my window 10 PC and MacBook though.

If I can get information on what kind of framework or technology Obsidian runs on in IOS, I could try to diagnose the bug.

IOS version 16.1, iPhone 13
Obsidian mobile version 1.4.1 with API version 1.0.3

I found a workaround to this.
The above comment mentioned the theme “Obsidianite” was able to solve this issues. Looking at the css code for that theme, I just copy and pasted the code as one of my CSS snippet.


I can confirm copying the LISTING STYLES part of that theme CSS out to a snippet works.

this should be fixed in 1.4.2+


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.