Bug - No note open panes cluttering screen on fresh app open

Are you using iOS or Android?

[x ] iOS
[ ] Android

Is this a bug report or a feature request?

[x ] Bug report
[ ] Feature request


Just installed version 0.13.

When I do a fresh open of the app (not running in the background), when the app opens I have my last open note and also two “no note open” pains next to it. I can close them but the next time I do a fresh open they are back again. Screenshot below:

Opening new notes from the URI has a similar effect for me, it opens the note always in a new pane, instead of replacing the old one.

@ryanjamurphy I think this shouldn’t be caused by your shortcut. Does it behave similarly for you?

I have also been playing with the Daily notes shortcut :sweat_smile:

@koala Did you figure out what was happening for you?

This is still happening on v0.14. I can’t seem to make it stop.

Yes, it stopped for me. @argentum made an improvement to her obsidian URI extension(?) to open a note for a particular day in the same pane.

That’s different to what you’re reporting though, I can’t repro that. Do you by any chance use Icloud which also syncs the workspace?

I have one vault setup with Obsidian Sync and one setup with iCloud. The only Vault I have the issue with is the one setup with Obsidian Sync. My sync folder is definitely not connected to iCloud.

Very odd.

I figured out what was causing it.

If Obsidian is open on multiple synced devices, the mobile app will open multiple panes whenever a note is opened.

The issue stopped when I quit Obsidian on my Mac.

I had this happen twice before and now that you posted this, it makes sense. That is the only times this has occurred, when the Mac was open.

Do y’all happen to have the Backlinks into the Document plugin enabled? I had a hunch the additional random lanes were related to that. Just a wild ass guess.

I do not. I don’t have that plug-in on the Mac, or the mobile.

I don’t have that plugin either and I get multiple windows open when I just open one window. I have even made sure that I don’t have Obsidian running on my Mac too.