[Bug] 'Flashing' issue when attempting to edit note


[ ] iOS
[X] Android

Obsidian Mobile version: v1.4.1 (83)
Android version: 13
Build: TP1A.220624.014.G986USQU3GVK1
Phone: Samsung Galaxy S20+ 5G


When ever try and edit a note of mobile this issue occurs. It happens for most every note, but seems to not happen ones that are short enough to have the entirety of their contents fit above the keyboard.

This has also caused all non-alphabetical characters to become red dots on 3 occasions, but I am not sure how.

I believe the latest Android update is when this issue appeared.

Im having a similar issue but only when I paste something. It will flash as above but each time it flashes it adds a blank line to the bottom of the note. Mine doesn’t change the colors however. I have had it change the characters to dots also but not every time.

I’m new to the app as of this week and it has happened from day one.
Android V. 13
Samsung S22 Ultra

1 Like

It interferes when creating backlinks, everytime it flashes it adds more ‘characters’.

Getting the same thing, on Samsung Galaxy S8+ tablet using the keyboard cover.

Same issue here on Galaxy S21 Ultra. Makes app basically unusable.

1 Like

I’ve been using Obsidian on my work Mac for months now; just started using it on my personal devices this week. I installed it on my Android phone yesterday and was shocked when I needed to look up some information while at the doctor and it started spazzing out like this (ultimately I couldn’t find what I needed). I’m glad to see it’s not just me!

Obsidian 1.4.1 (83)
API v1.0.3
Samsung Galaxy S22 SM-S901U
Android 13

Same issue here on samsung s21. Latest updates installed as far as i can see. Hope theres a fix.

1 Like

I just had to reformat a note on my desktop that got totally messed up (bullets, tables) on my phone.

I’m new to these forums; does this forum post constitute a formal bug report? Doe the developers typically acknowledge or interact at all? I’m just trying to set my expectations appropriately.


Per Black and red dots appear in my text (edit mode) and black dots and boxes with the text OBJ in view mode - #3 by ariehen I just tried disabling predictive text on my Samsung keyboard, and was able to successfully edit a note. I haven’t thoroughly tested this on other notes, and it’s not really a SOLUTION since I use predictive text, but I thought I’d mention it here.


This worked for me. Thanks.

1 Like